citizen-z

Why not upload photos to these photo listings?

10 posts in this topic

#1 ·  Posted

Help please

 

#include <iUploader.au3>


$sPicPath = 'c:\test.jpg'


    ;----------------TinyPic
        $sData = _HostTinyPicUpload($sPicPath)
        $aLinks = _HostTinyPicExtractLinks($sData)
            If Not @error Then
                ClipPut($aLinks[0])
                MsgBox(64,'Link TinyPic',$aLinks[0], '')
            Else
                MsgBox(64,'Error TinyPic','', '')
            EndIf
    ;----------------


    ;----------------ImGur
        $sData = _HostImGurUpload($sPicPath)
        $aLinks = _HostImGurExtractLinks($sData)
            If Not @error Then
                ClipPut($aLinks[0])
                MsgBox(64,'Link ImGur',$aLinks[0], '')
            Else
                MsgBox(64,'Error ImGur','', '')
            EndIf
    ;-------------------------


    ;--------------Imagebam
        $sData = _HostImagebamUpload($sPicPath)
        $aLinks = _HostImagebamExtractLinks($sData)
            If Not @error Then
                ClipPut($aLinks[0])
                MsgBox(64,'Link Imagebam',$aLinks[0], '')
            Else
                MsgBox(64,'Error Imagebam','', '')
            EndIf
    ;-------------------------


    ;----------------Postimage
        $sData = _HostPostimageUpload($sPicPath)
        $aLinks = _HostPostimageExtractLinks($sData)
            If Not @error Then
                ClipPut($aLinks[0])
                MsgBox(64,'Link Postimage',$aLinks[0], '')
            Else
                MsgBox(64,'Error Postimage','', '')
            EndIf
    ;-------------------------


    ;---------------BayImg
        $sData = _HostBayImgUpload($sPicPath)
        $aLinks = _HostBayImgExtractLinks($sData)
            If Not @error Then
                ClipPut($aLinks[0])
                MsgBox(64,'Link BayImg',$aLinks[0], '')
            Else
                MsgBox(64,'Error BayImg','', '')
            EndIf
    ;-------------------------

 

iUploader.au3

Share this post


Link to post
Share on other sites



#2 ·  Posted

Welcome to our forums. :)

Maybe a few pointers when posting a question:
Don't put the question in the title and say in the content that you need help with just supplying some code snippet and an attachment containing 1000 lines of code..... and then expecting anybody to try and guess what you really want and understand your problem.
I always give up right away when somebody doesn't take the effort to properly explain what they want and what exactly isn't working.
This time I took a little more effort to type this post to supply you with a pointer for a possible next step.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#3 ·  Posted

This code does not upload photos to photohosting.

Why?

Simple run this code and all understand.

Share this post


Link to post
Share on other sites

#4 ·  Posted

We don't have your iUploader.au3 file, what is that and where is it from?


UHJvZmVzc2lvbmFsIENvbXB1dGVyZXI=

Share this post


Link to post
Share on other sites

#5 ·  Posted

iUpload.au3 I found on the internet ...
He worked! But then one by one during the year 2017 the download on the photohosting stopped working ...
The first stopped working PostImage, then a month later TinyPic, etc.


but...
I do not care what to include ...
If you do not know the cause of the error in the include iUpload.au3, then please let me have your working include upload to 3-4 different photohostings ...

Share this post


Link to post
Share on other sites

#6 ·  Posted

It is very possible that those sites changed their upload process, and the UDF no longer works. You will have to update the UDF or somehow show it to us so we can see what is wrong with it.


UHJvZmVzc2lvbmFsIENvbXB1dGVyZXI=

Share this post


Link to post
Share on other sites

#7 ·  Posted

anthonyjr2 ,

yes sites changed their upload process.

But what UDF ?

 

Share this post


Link to post
Share on other sites

#8 ·  Posted

Please see all UDF in iUploader.au3

Share this post


Link to post
Share on other sites

#9 ·  Posted

So all of your examples don't work? If you found the UDF on the internet, maybe contact the original developer and see if they have an update available? I don't think anyone here wants to study the API of each of these sites just to fix your UDF for you. Most of them probably changed their process so it will need a lot of work.


UHJvZmVzc2lvbmFsIENvbXB1dGVyZXI=

Share this post


Link to post
Share on other sites

#10 ·  Posted

I thought this would be easy to fix.
But if it is difficult then do not know where to take a working example on uploading to the photo hostings?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now