Zerobug

ControlClick Issue - apostrophe in title

5 posts in this topic

#1 ·  Posted (edited)

Hi,

I'm trying a basic thing, I have already done with other program and it will works fine.

But, this time, not. Maybe because appostrophe in the "Title" ?

Someone can help me ? I'm trying to click on "OK" button, but it does'nt works.

2017-07-07_12-16-46.png

 

Many thanks for your help

Edited by Zerobug

Share this post


Link to post
Share on other sites



#2 ·  Posted

Good morning @Zerobug.

Considering that you're using WinWait and WinActive, which return the handle of the window you're interacting with, you could try to use the handle instead of the text of the title.

Make a little bit of debug and I'm sure that you'll find the way to do what you're trying to do :)

Let us know if you manage to do what you're trying to do :) 

 

Regards


Click here to see my signature:

Spoiler

I will always thank you for the time you spent for me.
I'm here to ask, and from your response, I'd like to learn.
By my knowledge, I can help someone else, and "that someone" could help in turn another, and so on.

Share this post


Link to post
Share on other sites

#3 ·  Posted

It could be your are trying to hit the Button to fast and need a little sleep() to give the application time to build up the screen.
The WinActive() statement doesn't do anything there, so am wondering what you think that does for you?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#4 ·  Posted

When I try with a computer in english, it work fine, because the Title is "Select Setup Language", without apostrophe.

This is why, I'm seeking issue was apostrophe.

Share this post


Link to post
Share on other sites

#5 ·  Posted

Ok, does the WinWait work? If so, use the WinHandle returned by WinWait() and remove the WinActive().

Else post your code in a <> codebox if you want help with the syntax.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now