Jump to content
Sign in to follow this  
Nick12345

_ArrayAdd help

Recommended Posts

Nick12345

I know that things changed with a recent version of AutoIT in regards to _ArrayAdd but I can't seem to figure out how to get my code to work again.  I know it's probably something stupid but I've been trying to get this to work for a few hours now and could use some help. 

Goal: add a row to the table with column 0 = $shortcutKey   and   column 1 = $shortcutDescription

 

I've tried setting the deliminator with Opt("GUIDataSeparatorChar","|") and with $sDelim_Item = "|".  I've tried using different a different deliminator like ";" or " - ".   I've tried just adding a row and then filling it by addressing each cell...  A few other things but overall I'm not getting anywhere.  I'd refer to the help but the help for _ArrayAdd is still referring to the same method I was doing

I would really appreciate some help with this, can you please show me what I'd have to do in this new version (v3.3.14.3)

 

HotKeySet_AndHelp($shortcutKey,$shortcutDescription)
    ;Assign Hotkey
    HotKeySet($shortcutKey,$shortcutDescription)
    Local $arrayAddition = $shortcutKey & "|" & $shortcutDescription
    _ArrayAdd($helpArray,$arrayAddition)
EndFunc

Func clearHelp()
    ReDim $helpArray[2][2]
    $helpArray[0][0] = "{F10}"
    $helpArray[0][1] = "Help"
    $helpArray[1][0] = "{END}"
    $helpArray[1][1] = "Exit Program"
EndFunc

 

Share this post


Link to post
Share on other sites
JLogan3o13

@Nick12345 Are you using the interim fix for _ArrayAdd seen here?

 

 


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×