Jump to content
aByte

SEND STRG(CTRL) + ALT + F4

Recommended Posts

Hello,

I'm not trying to do a script in AUTOIT. The Edge Browser should be started and the open windows should be closed.
The key combination for this is CTRL + ALT + F4.
closes all tabs except the active tab.
My script is really simple but it doesn't work. What am I doing wrong?

 

$url = "https://google.de"
    ;Edge starten
    RunWait(@ComSpec & " /c start microsoft-edge:" & $url ,"",@SW_HIDE)
        
    ;Beim Edge schließen wir noch die alten Fenster
    Sleep(1000)
    Send("{CTRLDOWN}{ALTDOWN}{F4}{CTRLUP}{ALTUP}")

 

Share this post


Link to post
Share on other sites

You're using RunWait, which means the script pauses until the program started with the Run closes. Then the rest of the script runs, so those commands aren't going to the right window, because Edge is not running any longer.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Hello,

Thanks for the quick answer. I have now replaced RUNWAIT with RUN. No change.

$url = "https://google.de"
    ;Edge starten
    Run(@ComSpec & " /c start microsoft-edge:" & $url ,"",@SW_HIDE)
        
    ;Beim Edge schließen wir noch die alten Fenster
    Sleep(1000)
    Send("{CTRLDOWN}{ALTDOWN}{F4}{CTRLUP}{ALTUP}")

 

Share this post


Link to post
Share on other sites

Hello,

no change when I perform it manually so "Real" with the keys it works. Do I have to select the window first?
If so, how do I do it?

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, if you want to send the command to an instance of Microsoft Edge, then you will need to make sure it is active before sending the command.  Assuming that there is an Edge window open, the following snippet worked for me.  Check out the Win* functions in the Help file for more information.

WinActivate("[REGEXPTITLE:.*Microsoft Edge$]")
Sleep(100)
Send('^!{f4}')

 

Edited by TheXman

Share this post


Link to post
Share on other sites

Unusually sometimes (every 10 times) it works. And then again not, I have also played with the Slepptimes of this it seems to sen independently.

To check it I used the shortcut for fullscreen before entering it. Also this is only executed occasionally.

$url = "https://google.de"
    ;Edge starten
    Run(@ComSpec & " /c start microsoft-edge:" & $url ,"",@SW_HIDE)
    
    ;Edge Vollbild
    Sleep(2000)
    Send("{ALTDOWN}{SPACE}{x}{ALTUP}")
    
    ;Beim Edge schließen wir noch die alten Fenster
    WinActivate("[REGEXPTITLE:.*Microsoft Edge$]")
    Sleep(1000)
    Send('^!{f4}')

 

Share this post


Link to post
Share on other sites

Oh, I noticed something. In the browser the URL window opened, this happens with the key F4, if I press you alone.
Could it be that not all keys are pressed at the same time?

 

Share this post


Link to post
Share on other sites

the following snippet works:

Send("{CTRLDOWN}{ALTDOWN}{F4DOWN}{F4UP}{CTRLUP}{ALTUP}")

Share this post


Link to post
Share on other sites

Sorry I can't edit my posts. Now it doesn't work again.

$url = "https://google.de"
    ;Edge starten
    Run(@ComSpec & " /c start microsoft-edge:" & $url ,"",@SW_HIDE)
    
    ;Edge Vollbild
    Sleep(2000)
    Send("{ALTDOWN}{SPACE}{x}{ALTUP}")
    
    ;Beim Edge schließen wir noch die alten Fenster
    WinActivate("[REGEXPTITLE:.*Microsoft Edge$]")
    Sleep(1000)
    Send('^!{f4}')
    Send("{CTRLDOWN}{ALTDOWN}{F4DOWN}{F4UP}{CTRLUP}{ALTUP}")

 

Share this post


Link to post
Share on other sites

After a run command its allways more robust to use winexists winwaitactive winactive winactivate before proceding with other code. Sleep is sometimes needed to give your gui some time to draw.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...