Jump to content
Sign in to follow this  
Grof

Registry (let start!).

Recommended Posts

i can confirm that i cannot use Alt-I to automatically load .au3 files in the User defined Include directory

this compiles

#include "_RegFunc.au3"

Local $REGISTRYKEY1 = "HKEY_CURRENT_USER\Software\MyApp"
Local $PORTABLEKEY1 = "Backup\MyApp.reg"

Call ("_RegMoveKey", $REGISTRYKEY1, $REGISTRYKEY1 & "-Backup")
Call ("_RegCopyKey", $PORTABLEKEY1, $REGISTRYKEY1)

but Alt-I doesn't auto open it, if you put that udf into the global include folder, it will open just fine. anyway, good luck. you will need it.

#include <_RegFunc.au3> 

works as well, but no auto load if it's not in global include folder.

i would never use call, no need. useless really, just adding overhead. call the functions direct, and capture their return, and check for errors

so, if you can't figure out what the differences in our code is, then nobody here can help you really.

that code above compiles, but I am not going to test it.

Edited by Earthshine

My resources are limited. You must ask the right questions

 

Share this post


Link to post
Share on other sites
1 minute ago, Earthshine said:

i can confirm that i cannot use Alt-I to automatically load .au3 files in the User defined Include directory

Have you added the directory path to your SciteUser.properties? Something like this is required where the latter part needs to contain the fully qualified path to your private includes:

openpath.$(au3)=$(SciteDefaultHome)\..\include;C:\Program Files (x86)\AutoIt3\Include_prive

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

This is the page in the SciTE helpfile that descibes the setup: https://www.autoitscript.com/autoit3/scite/docs/SciTE4AutoIt3/SciTE4AutoIt3-UserCallTips.html

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

@Jos, I had no permissions to change that file as I have UAC enabled. now it works. I added it to the file and it works fine.

Edited by Earthshine

My resources are limited. You must ask the right questions

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...