Jump to content
Shark007

Scite improvement suggestion

Recommended Posts

Posted (edited)

I use a 4k monitor @ 200% resolution. The icons beneath the header panel are much to small.
On my screen, and with my 60 year old eyes, it is difficult to distinguish between them.
The text displays fine.

When I remove DPI Aware'ness by editing the Scite.exe manifest,
They become normal size but of lessor quality because now they are bitmap stretched by the OS.

Posted solely to inform.
If you do not own a 4k monitor for personal testing while trying to improve this situation,
I offer my services to test things for you.
You probably just need to add some $scaling as described in the 1st post of my DPI thread.

Edited by Shark007

Share this post


Link to post
Share on other sites

I am using the standard manifest, supplied by Neil, from the original SciTE source:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1"
                 manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
<assemblyIdentity
    version="1.0.0.0"
    processorArchitecture="*"
    name="Scintilla.SciTE.SciTE"
    type="win32"
/>
<description>SciTE</description>
<asmv3:application>
    <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
        <dpiAware>true</dpiAware>
    </asmv3:windowsSettings>
</asmv3:application>
<dependency>
    <dependentAssembly>
        <assemblyIdentity
            type="win32"
            name="Microsoft.Windows.Common-Controls"
            version="6.0.0.0"
            processorArchitecture="*"
            publicKeyToken="6595b64144ccf1df"
            language="*"
        />
    </dependentAssembly>
</dependency>
<!-- Identify the application security requirements. -->
<!-- level can be "asInvoker", "highestAvailable", or "requireAdministrator" -->
   <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
      <security>
      <requestedPrivileges>
        <requestedExecutionLevel
          level="asInvoker"
          uiAccess="false"/>
      </requestedPrivileges>
    </security>
   </trustInfo>
</assembly>

So you could make any suggestions there in case you like this to be changed.
I know how big this trap is fiddling around with this setting so aren't  making any changes myself unless it is 100% clear things keep working correctly. :) 

Jos

Share this post


Link to post
Share on other sites

The problem is not in the Manifest but caused by the usage of DPI Aware in the manifest. Which is a good thing.

I had assumed, possibly wrongly, that Scite was written in AutoIt.

So does this mean you are not able to edit the actual Scite code, and get the icons scaled according to the OS resolution?

Share this post


Link to post
Share on other sites
Posted (edited)
12 minutes ago, Shark007 said:

So does this mean you are not able to edit the actual Scite code, and get the icons scaled according to the OS resolution?

I maintain our own version of the original SciTE source with several modifications we needed for AutoIt3,

so Yes, I do have the source and can modify stuff but will limit these changes to Autoit3 specific things as I upgrade from Neil's original version each time.

Jos

Edited by Jos

Share this post


Link to post
Share on other sites

It is not a big enough issue (to me) to pursue this further.

It is quite easy for me to edit the scite manifest and remove the dpiaware code of the compiled exe.

Share this post


Link to post
Share on other sites

I downloaded the official Scite, ver 4.2.0 and the icons display properly without any hackery.

So either you need to update you version of scite, or your autoit edits are at cause.

Share this post


Link to post
Share on other sites

Sometimes I just hate working with Windows.

I was going to make some Screenshots so you could see what I see but now your scite is displaying correctly.

This is far from the 1st time  I have had this happen and it all has to do with DPI crap. 

The most likely cause; I didn't sign out of Windows after a resolution change.

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/9/2019 at 7:22 PM, Shark007 said:

I downloaded the official Scite, ver 4.2.0 and the icons display properly without any hackery.

So either you need to update you version of scite, or your autoit edits are at cause.

Strange as the included "SciTE.exe.manifest" file looks the same to me. What is different in the program's manifest?

On 8/9/2019 at 7:36 PM, Shark007 said:

I was going to make some Screenshots so you could see what I see but now your scite is displaying correctly.

This is far from the 1st time  I have had this happen and it all has to do with DPI crap. 

The most likely cause; I didn't sign out of Windows after a resolution change.

Ah, ok ...  maybe that is the reason.

Jos

Edited by Jos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...