Jump to content
Sign in to follow this  
CanadianGuy420

AutoIt script only updates 10 times a second? - (Moved) - (Locked)

Recommended Posts

I'm creating a few scripts and I've found that I can only call a function once every 100 milliseconds? 

I'm watching cpu usage and there is literally not impact from my current script so I was wondering if there was a way to force autoit to update more than 10 times a second?

Share this post


Link to post
Share on other sites
2 hours ago, CanadianGuy420 said:

I was wondering if there was a way to force autoit to update more than 10 times a second?

Change line 15?

Jos

PS: We seriously need more information in case you want a real answer. ;) 


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Moved to the appropriate forum, as the Developer General Discussion forum very clearly states:

Quote

General development and scripting discussions. If it's super geeky and you don't know where to put it - it's probably here.


Do not create AutoIt-related topics here, use the AutoIt General Help and Support or AutoIt Technical Discussion forums.

Moderation Team


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Hi again! Sorry about that I never really use internet forums ill do my best to refrain from posting in the wrong section again.

While 1
    If _IsPressed(01) And $ReadyToBuild Then
        Build()
     Else
        Reset();
    EndIf
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case $GUI_EVENT_CLOSE
            Exit

    EndSwitch
 WEnd

 Func Build()
    bMove($ouseX[$cycles], $mouseY[$cycles])
    $cycles += 1
    ;Sleep(130)
EndFunc

I'm not sure if this matters but this is for building in a single player game called 7 days to die, I'm not trying to cheat fortnite or anything. It works to move the mouse around and build but for some reason I can only call the Build function once every 100 milliseconds. I figured that after removing the Sleep function the program would call build crazy fast and work through the whole program instantly but it just calls the function once every 100 milliseconds despite the fact I'm holding down the mouse.

I thought the While 1 loop would check every 1 millisecond?

Share this post


Link to post
Share on other sites

Welcome to the AutoIt forum.

Unfortunately you appear to have missed the Forum rules on your way in. Please read them now - particularly the bit about not discussing game automation - and then you will understand why you will get no help and this thread will now be locked.

See you soon with a legitimate question I hope.

The Moderation team


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...