Jump to content

Recommended Posts

I had a really weird problem, code which I deleted seemed to still be executing somehow

even though it was no longer present anywhere in my code!

 

It behaved like a function registered with AdLibRegister, but it was not even a function, it was just a simple infinite while loop

with two ConsoleWrite functions inside.

 

I fixed it by running a different script before running it again. Does anyone know what could've caused this?

Link to post
Share on other sites

Of course we don't know because you haven't given us any information. All very vague. If you show us an example of the code we may be able to help.

You have to ensure that the code is not running when you compile your changes. If you didn't look closely at the output window you may not have noticed that the compile didn't complete.

 

Phil Seakins

Link to post
Share on other sites

I basically had something like this below my includes to test something

While 1
    ConsoleWrite("Loop" & @CRLF)
    Sleep(100)
WEnd

Which I then deleted

Then it still printed "Loop" every time I ran the script after that (by pressing F5 in SciTE). Normally SciTE doesn't allow me executing two scripts at the same time, but if that somehow happens would the "Loop" from the previous script still show up in the output after you reopen SciTE?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...