Jump to content

How to send "#" using Send() function - (Moved)


Recommended Posts

37 minutes ago, MateusAMOK said:

is running: XF067EAAB9
but it should be: XF067EA#AB9

Try the flag $SEND_RAW 

Example :

#include <AutoItConstants.au3>
#include <WinAPISys.au3>
Run("notepad.exe")
Local $hWnd = WinWaitActive("[CLASS:Notepad]", "", 5)
If Not WinWaitActive($hWnd, "", 5) Then Exit MsgBox (BitOR(4096, 16),"","Error starting Notepad")
Local $excelCompatibilidade = "XF067EA#AB9"
Send($excelCompatibilidade, $SEND_RAW)
Sleep(1000)
WinClose($hWnd)

or :

[...]
Local $excelCompatibilidade = "XF067EA{#}AB9"
Send($excelCompatibilidade) ; uses default flag $SEND_DEFAULT (0) 
[...]
Edited by Musashi
typo

Musashi-C64.png

"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."

Link to post
Share on other sites
  • Developers

Please pay attention where you post as this is not the first time we move a thread!
Moved to the appropriate forum, as the Developer General Discussion forum very clearly states:

Quote

General development and scripting discussions.


Do not create AutoIt-related topics here, use the AutoIt General Help and Support or AutoIt Technical Discussion forums.

Moderation Team

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...