Jump to content

Recommended Posts

Not sure what you mean, the error will be shown below the text you've written for example:

#include <WinAPIError.au3>

Run("Error", "", @SW_HIDE)
_WinAPI_ShowLastError("Line Number: " & @ScriptLineNumber & @CRLF & "Install Latest Version Error", True)

Resulting Window

Quote

 

Line Number: 4
Install Latest Version Error

The system cannot find the file specified

 

 

Edited by Subz
Link to post
Share on other sites

I have changed my RunWait to this:

Quote

RunWait('msiexec.exe /i "C:\Dnload\9xAddons\VNC UltraVnc_1_3_81_X64.msi /loadinf=VNCConfig.ini /props=VNCsetup.reg /silent" /quiet    /qb-')
   

Which doesn't give me any errors but the program doesn't install

So something is wrong with my .msi options.

Edited by Docfxit
Link to post
Share on other sites
3 minutes ago, Subz said:

Have you tried using quotes around the path:

RunWait('msiexec.exe /i "C:\Dnload\9xAddons\VNC UltraVnc_1_3_81_X64.msi" /loadinf=VNCConfig.ini /props=VNCsetup.reg /silent /qb-')

Yes.  I tried that.  I think the msiexec.exe was looking at the /silent switch and didn't think it was valid. The /silent switch is for the ULTRAVNC install.

Link to post
Share on other sites

I removed the space in the file name

For some reason the program isn't installing.

RunWait('msiexec.exe /i "C:\Dnload\9xAddons\VNCUltraVnc_1_3_81_X64.msi /loadinf=VNCConfig.ini /props=VNCsetup.reg /silent" /quiet /qn')

 

Edited by Docfxit
Link to post
Share on other sites

You seem to be mixing ".exe" switches with ".msi" switches

To install UltraVNC (downloaded directly to C:\Dnload\9xAddons\UltraVnc_1381_x64

Installs fine with the following:

RunWait('msiexec.exe /i "C:\Dnload\9xAddons\UltraVnc_1381_X64.msi" /qb')

If you want to modify the settings either use ultravnc 1381 X64 setup.exe and use the following:Installation - UltraVNC VNC OFFICIAL SITE, Remote Desktop Free Opensource (uvnc.com)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...