Jump to content
Sign in to follow this  
CyberSlug

Autobuilder

Recommended Posts

@SlimShady: I aplogolize for the delay in reponding. I probably forgot to unregister old hotkeys when creating the new save dialog. Try adding the following code to the beginning of "_fileMenu.au3":

HotKeySet("!s")            
HotKeySet("!t")            
HotKeySet("!g")           
HotKeySet("{Esc}")
HotKeySet("{Delete}")
HotKeySet("{F5}")
HotKeySet("{Tab}")
HotKeySet("!{Tab}")
HotKeySet("{Enter}")
HotKeySet("{Pause}")

@kalayann: :D Edit line #31 in "_generator.au3" Thanks


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

I apologize for not having any updates recently.

I have tried compiling AutoBuilder with recent versions of AutoIt, and things have not worked well.... so I might wait until Jon finalizes the message loop until I start fixing my code....

My to-do list--unless anyone writing a GUI builder in C++ or more-capable language :D

1) Regarding Tab and Shift-Tab to cycle grippy focus on controls: I forgot to exclude items that are hidden on tab controls....

2) Ability to set styles exStyles

3) Lots of other stuff I need to officially write down


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

The best thing since sliced bread .

Keep up the good work man, i love that program ..

:D

Share this post


Link to post
Share on other sites

I imagined that in this version the cursors would be included. Fine, CyberS. :)

Only that, I see problems when I want move a combo control.  :D

@josbe:

You can use Tab to select the control, Enter to begin "move mode", and Esc to cancel "move mode". I knew there was a reason I provided those hotkeys :huh2:

Other things on the to-do list (notes to self):

- Instead of loading 4 grid backgrounds and 4 blank files, I should load 4 images and use the new-ish feature to re-load an image.

- Tray icons can be hidden; Helper and Main should minimize/restore together


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

@SlimShady:  I aplogolize for the delay in reponding.  I probably forgot to unregister old hotkeys when creating the new save dialog.  Try adding the following code to the beginning of "_fileMenu.au3":

HotKeySet("!s")            
HotKeySet("!t")            
HotKeySet("!g")           
HotKeySet("{Esc}")
HotKeySet("{Delete}")
HotKeySet("{F5}")
HotKeySet("{Tab}")
HotKeySet("!{Tab}")
HotKeySet("{Enter}")
HotKeySet("{Pause}")

@kalayann:  :D  Edit line #31 in "_generator.au3" Thanks

That worked well.

But I don't use it all the time. Here are the reasons:

  • When I'm moving an object everything starts to flicker. (And I mean everything!)
  • One time, but happened before, when I want to move an object, the mouse jumps to a totally random location and stays there until I press ESC
I assume this has to do something with my computer (but actually I doubt that).

That's why I haven't posted this earlier.

Share this post


Link to post
Share on other sites

  • When I'm moving an object everything starts to flicker. (And I mean everything!)

  • One time, but happened before, when I want to move an object, the mouse jumps to a totally random location and stays there until I press ESC
:D Probably a combination of AutoBuilder bugginess and AutoIt-Gui unstableness.

If you use the provided Main.exe, you should not get flicker--except for Tab controls.... Also, AutoBuilder only compiles well with certain late May / early June versions of AutoIt.

What CPU speed and Windows OS?


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

AutoBuilder 0.4.2 only small changes

Basically I just wanted to *BUMP* this thread, but I felt obligated to make some improvements: :ph34r:

Changes over 0.4.1:

- Should compile with latest AutoIt build

- GUI should be more responsive

- no longer has special mouse cursors (resize, etc)

Details behind changes:

1) In early AutoIt builds, the first gui control ref# was 1; and AutoBuilder 0.4.1 assumed my grippy controls were indexed 1 to 8. Later AutoIt builds set the first gui ref index as 3, and that change broke a lot of my hard-coded grippy code. I now use the constant $FIRST_GUI_REF in my code to avoid this problem in the future.

2) I replaced lots of sleep(100) statements with sleep(10) in order to make the AutoBuilder more responsive.

3) GUISetCursor was "broken" shortly after it was introduced: A custom mouse cursor is not displayed when the mouse is over a control. Because the background of AutoBuilder is one big image control (to detect mouse clicks), custom mouse cursors never appear--or the revert to the arrow cursor a split-second after appearing....


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

OMG, I started a new script today & have just spent about 3 hrs slogging through the HelpFile, trying to understand how to create the GUI that I need.

About 5 minutes ago I gave up trying for myself (if I can do it myself then I feel better than if I get help, as do we all :ph34r:).

Did a search on here re: "gui" & found this program. Thought I'd give it a go (it has 5 pages of notes, & a couple of updates already). Read the Readme, ran the program...

...and IT WORKED 1ST TIME!!!

The Gui is nearly finished, I just need to edit it some.

THANK YOU VERY MUCH :(:lol: :lol:

w_sp8er

ps. that'll teach me not to check here before I start to bang my head against the wall!!! :D

Edited by w_sp8er

Share this post


Link to post
Share on other sites

As a non-programmer looking for a way to get some needed things done, I have a suggestion for Autobuilder (great program by the way).

How about developing/adding a way to more easily connect action/events from clicking/pressing/moving buttons, checkboxes, etc....?

You build the GUI and get it the way you want it to look and then maybe a menu could come up that would help you select the commands that you want once a button, checkbox, etc... was clicked. So then you would have the code for the GUI and what happens as the result of button pushes and clicks (for example) in the code that you will copy to an editor.

This would be/could be a hyper speed visual IDE. It would not have to perfect or "all powerful" about selecting the commands for the buttons, etc... either, because if it was integrated with SciTe the user could take the "framework" of what they started and complete it in the editor. This method would just help to create more of a GUI program faster.

Interested in everyone's opinions.

Edited by autoitNOW

An ADVOCATE for AutoIT

Share this post


Link to post
Share on other sites

;Script generated by AutoBuilder 0.4


Opt("GUICoordMode", 1)
Opt("GUINotifyMode", 0)
GuiCreate("Network+ 2.5i Launcher", 183,64,(@DesktopWidth-183)/2, (@DesktopHeight-64)/2 , 0x04CF0000)

$button_1 = GUISetControl("button", "Button 1", 10, 0, 160, 30)
$label_1 = GUISetControl("»Launch«", "Label 1", 10, 40, 160, 20)

GuiShow()

While 1
    sleep(100)
    $msg = GuiMsg(0)
    Select
    Case $msg = -3
        Exit
    Case $msg = 1
       ;;;
    Case $msg = $button_1
       ;;;
    Case $msg = $label_1
       ;;;
    EndSelect
WEnd
Exit

and the error

>Running AU3Check...
C:\Program Files\AutoIt3\AutoBuilder 0.4.2\Network+ 2.5i Launcher.au3(5,22) : ERROR: Opt() called with illegal argument 1: "GUINotifyMode"
Opt("GUINotifyMode, 0)
~~~~~~~~~~~~~~~~~~~~~^
C:\Program Files\AutoIt3\AutoBuilder 0.4.2\Network+ 2.5i Launcher.au3(8,61) : ERROR: GUISetControl(): undefined function.
$button_1 = GUISetControl("button, "Button 1, 10, 0, 160, 30)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\Program Files\AutoIt3\AutoBuilder 0.4.2\Network+ 2.5i Launcher.au3(11,9) : ERROR: GuiShow(): undefined function.
GuiShow()
~~~~~~~~^
C:\Program Files\AutoIt3\AutoBuilder 0.4.2\Network+ 2.5i Launcher.au3(15,20) : ERROR: GuiMsg(): undefined function.
    $msg = GuiMsg(0)
~~~~~~~~~~~~~~~~~~~^

Any input on how to get this working?


~Projects~1. iPod Ejector 1.0 - Tool Used To Eject iPod in Windows - Uses DevEject.exe :P2. SmartFTP Close Popup Tool - Closes reminders from freeware SmartFTP.~Helpful Links For New Users~1. LXP's Learning AutoIT PDF Guide - <<< Go here for a PDF Guide on learning AutoIT from the ground up!<<<2. AutoIt 1-2-3 <<<Want to learn more about AutoIT quickly? Go Here<<<3. How To Install The Beta And Production Versions Of AutoIT / SciteAutoIT

Share this post


Link to post
Share on other sites

Any input on how to get this working?

Looks you're using outdated version which is using the initial GUI BETA syntax...

Need to use the latest GUIBuilder....


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...