Jump to content

Graphical AutoIt Debugger


Recommended Posts

  • Replies 430
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Here is the first new issue of the debugger for a long time! Error List: Variables: Tool Chest: Class Viewer: Features: Automatic updates. COM operation replaced with Windows messaging (sc

thanks, this helps alot ^^

My code is: $in = '["1230A1+4560B3B","Inspect door, install knob, replace hinge",False,$K99P2],_' $vec = StringSplit($in,",") local $vec2[ubound($vec)] $i = 0 $j = 0 $saved = "" For $i = 1 to ubound

Posted Images

@MCP - Stumpii is a well respected member of the community, you've most likely been a victim of a false positive. Please look here.

Well, I know and I have never attacked or flamed anyone even in the old days of BBS's and newsgroups. But I would check the site that might have been hacked. I am a pro as well, and my outdated Joomla has been injected.

EDIT: Stumpii, please do not think I was joking or acting badly. I wasn't. I am sorry If anyone may think I was.

Edited by MCP
Link to post
Share on other sites

Well, I know and I have never attacked or flamed anyone even in the old days of BBS's and newsgroups. But I would check the site that might have been hacked. I am a pro as well, and my outdated Joomla has been injected.

EDIT: Stumpii, please do not think I was joking or acting badly. I wasn't. I am sorry If anyone may think I was.

No problem! I have downloaded and installed from the website and scanned for viruses with the latest McAffee, and it did not detect anything. I also compared the exe and zip files on the web against those on my pc and they are identical.

Thanks for letting me know.

Stumpii

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites
  • 4 weeks later...

I've been using Graphical Debugger for about two weeks now, and I can't live without it. It's enabled me to find the seemingly endless number of bugs I introduce every time I try to code something much faster than I ever would be able to without it. A huge thanks to Stumpii for this fantastic app!

Today, though, I lost the ability to run it from SCITE's menu. I haven't changed anything (that I know of). When I try to debug an app through the menu, I get the following message:

>D:\Program Files\Apps\AutoIt3\AutoIt Debugger\AutoIt Debugger.exe "D:\Program Files\Apps\AutoIt3\#Scripts#\Daggerfall MultiPort\Memaccessv1.0.au3"

>%1 is not a valid Win32 application.

That's the correct path for the debugger. I thought perhaps the # signs in the script path might be causing the problem (even though I've been debugging that script in that path successfully for several days now), but I can't run the debugger with any scripts. Scite's config file still has the correct menu entry:

# 35 Stumpii's Graphical Debugger

command.35.*.au3=$(autoit3dir)\AutoIt Debugger\AutoIt Debugger.exe "$(FilePath)"

command.name.35.$(file.patterns.au3)=Graphical Debugger

I can still run the debugger manually and open the file I want to debug; I've just lost the menu functionality in Scite. I've tried uninstalling and reinstalling - no love. Anybody have any ideas?

Link to post
Share on other sites

I've been using Graphical Debugger for about two weeks now, and I can't live without it. It's enabled me to find the seemingly endless number of bugs I introduce every time I try to code something much faster than I ever would be able to without it. A huge thanks to Stumpii for this fantastic app!

Today, though, I lost the ability to run it from SCITE's menu. I haven't changed anything (that I know of). When I try to debug an app through the menu, I get the following message:

>D:\Program Files\Apps\AutoIt3\AutoIt Debugger\AutoIt Debugger.exe "D:\Program Files\Apps\AutoIt3\#Scripts#\Daggerfall MultiPort\Memaccessv1.0.au3"

>%1 is not a valid Win32 application.

That's the correct path for the debugger. I thought perhaps the # signs in the script path might be causing the problem (even though I've been debugging that script in that path successfully for several days now), but I can't run the debugger with any scripts. Scite's config file still has the correct menu entry:

# 35 Stumpii's Graphical Debugger

command.35.*.au3=$(autoit3dir)\AutoIt Debugger\AutoIt Debugger.exe "$(FilePath)"

command.name.35.$(file.patterns.au3)=Graphical Debugger

I can still run the debugger manually and open the file I want to debug; I've just lost the menu functionality in Scite. I've tried uninstalling and reinstalling - no love. Anybody have any ideas?

Have you tried removing the two periods from the filename? I do not know if that would have any effect.

The debugger works fine if you right click an 'au3' file and select debug?

Stumpii

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

Actually, I hadn't even noticed that you could right-click and choose "Debug." Heh. That works okay. The only thing that doesn't work is running it from within Scite. And it doesn't work with ANY scripts, no matter their name or location. That was just the script I happened to have loaded while I was writing the question.

I think I'm going to try uninstalling and then reinstalling Scite. Since GD seems to be working every other way, maybe the problem is within Scite.

Link to post
Share on other sites

Seem to have fixed it. I uninstalled GD and Scite, completely removed their folders, reinstalled Scite and then GD, and manually added in the commands in Scite (the installer does not do this automatically?) to run GD from within it. Loaded a script, hit "Graphical Debugger", and got the error message. Aaaargh!!

Then, on a whim, I added '"' around the exe portion of GD's run command:

command.35.*.au3=$(autoit3dir)\AutoIt Debugger\AutoIt Debugger.exe "$(FilePath)"

became

command.35.*.au3="$(autoit3dir)\AutoIt Debugger\AutoIt Debugger.exe" "$(FilePath)"

Worked perfectly. I have no idea why it would work just fine the way it was for two weeks and probably hundreds of uses (I write a LOT of bugs), then suddenly stop. Like I said, I don't think I changed anything, even anything not pertaining to AutoIt. Oh well, I'm just happy it's working once again.

Once again, Stumpii, thanks a lot for this program. With the exception of Scite, this is far and away my most used AutoIt tool.

Link to post
Share on other sites

@ GWmellon:

Hi.

I thank you for your info, I have been a victim myself.

I was not talking about the stumpii's exe, but about the installer. My download server doesn't pass the file to me if it detects a threat, so I can't determine if it contains only the AutoIt compiled script, or anything else, really infected or not.

I had downloaded the beta release of AutoIt (with and without installer) some minutes before.

Even if it is a false positive, I can't directly talk to the AV company, 'cause I'm not the direct user of their product.

At last, if I would be the author (I wish I would!), I'd like to know about it, and that's why I posted it.

Best wishes to all AutoItians

alc

I have checked the file again with the McAffee and the file is clean. MCP also had this problem as detailed here.

I too would rather know about any potential problems, so thanks for letting me know.

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites
  • 2 months later...

I just installed this debugger, so far it looks nice, although I found a bug... not sure if this is the right place to put it, but basically this is what is happening.

I declared a variable with a comment next to it.

Global $gPath; = $ProjectPath & '\Forms'

I get an error from the debugger stating that the $ProjectPath variable is being used and isn't declared, however if you'll notice, the $ProjectPath variable is commented out. I've searched through my code and I don't use $ProjectPath anywhere in my code, I just have it listed in comments.

(this is the line from the debugger version of the code)

Global $gPath; = $ProjectPath & '\Forms'

AutoIt_Debugger_FinishedLine("C:\AutoIT Scripts\Grabber\Grabber.au3", "Grabber", 24, @error, @extended, False)

AutoIt_Debugger_SendVariable("$gPath", $gPath, @error, @extended)

AutoIt_Debugger_SendVariable("$ProjectPath", $ProjectPath, @error, @extended)

AutoIt_Debugger_NextLine("C:\AutoIT Scripts\Grabber\Grabber.au3", "Grabber", 25, False)

Anyways, it's easy to get around, I just removed the $ from the comments...

Scrubby

Link to post
Share on other sites

Hi

Just installed the Debugger and tested it with the "Test Script.au3". After a few seconds I get an error box "AutoIt Debugger GUI" which starts with:

---------------------------

System.ComponentModel.Win32Exception: Window class name is not valid.

at System.Windows.Forms.Nativewindow.WindowClass.RegisterClass()

at System.Windows.Forms.Nativewindow.WindowClass.Create(String className, Int32 classStyle)

...

---------------------------

and then another one:

---------------------------

System.NullReferenceException: Object reference not set to an instance of an object.

at AutoIt_Debugger.frmCode.GetListView(String Filepath)

at AutoIt_Debugger.frmMain.NewLine(String Filepath, String Filename, Int32 LineNumber, Boolean SkipLine)

---------------------------

Had to kill the Debugger with the Task Manager.

I have XP SP2, with .NET 2.0 installed.

Any suggestions?

TIA

Alex

Link to post
Share on other sites
  • 4 weeks later...

Hi,

I want remove AutoIt_Debugger release 0.10.1 and I want install the current release 0.11.0

Unfortunately I have deleted the old installation files.

I am trying to uninstall the old relase using the control panel, but I need the file AutoIt_Debugger_GUI_v0.10.1_Setup.msi to proceed.

At the moment seems impossible to uninstall the old release of debugger.

Can anyone help me?

Link to post
Share on other sites

Hi,

I want remove AutoIt_Debugger release 0.10.1 and I want install the current release 0.11.0

Unfortunately I have deleted the old installation files.

I am trying to uninstall the old relase using the control panel, but I need the file AutoIt_Debugger_GUI_v0.10.1_Setup.msi to proceed.

At the moment seems impossible to uninstall the old release of debugger.

Can anyone help me?

You can get it from here: http://www.thefoolonthehill.net/AutoIt_Aut...tup_v0.10.1.exe

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites
  • 3 months later...

Finally a new issue. This is quite a re-write and takes the debugger in the direction I always wanted it to go.

Refer to the first post for more details.

Thanks go to Banshee for helping me test this new version.

Edited by Stumpii

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

Here is the first new issue of the debugger for a long time!

Posted Image

Features:

  • New interface.
  • Automatic updates.
  • COM operation replaced with Windows messaging (script no longer closes when program finishes).
  • New output window.
  • Toggle between Release and Debug AutoIt.
  • ScintillaNET editor looks and feels the same as SciTE.
  • Single step debug through your script and #include files.
  • Debug script in compiled or script form.
  • View and modify variable values while your program is running. Allows you to test all parts of you program.
  • Breakpoints (toggled by clicking on the line number).
  • Scripts can be debugged by right clicking on the au3 file, running the debugger from the Start>Programs menu, from UltraEdit/UEStudio by using AutoIt4UE, or from within SciTE with this mod.
  • Portable version (just install and select 'Portable' instead of 'Full').
  • Script editing.
Upcoming features (don't hold your breath though!):
  • Detection of changes in the script and prompt to automatically restart
  • Storing of breakpoints between sessions
  • Variable breakpoints (stop if x>1, or @error=1)
  • Variable value tooltips in the code window
  • Some method of jumping back in the script to an earlier line without restarting. Don't really know if this is possible without the GOTO command.
  • Some sort of variable value popup window to allow long strings to be viewed
  • Performance enhancements
  • Run to Cursor option in code window
Here is link to a web page for the program: Autoit Debugger
I have an error:

Error - Window class name is not valid.

Error Information 
Name Value 
Source System.Windows.Forms 
Message Window class name is not valid. 
TargetSite Void RegisterClass() 
StackTrace at System.Windows.Forms.Nativewindow.WindowClass.RegisterClass() at System.Windows.Forms.Nativewindow.WindowClass.Create(String className, Int32 classStyle) at System.Windows.Forms.Nativewindow.CreateHandle(CreateParams cp) at System.Windows.Forms.Control.CreateHandle() at System.Windows.Forms.Control.get_Handle() at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.SendMessageDirect(UInt32 msg, IntPtr wParam, IntPtr lParam) at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.SendMessageDirect(UInt32 msg, Int32 wParam, Int32 lParam) at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.GetCodePage() at ScintillaNet.Scintilla..ctor(String sciLexerDllName) at AutoIt_Debugger.frmdocument.InitializeComponent() at AutoIt_Debugger.frmdocument..ctor() at AutoIt_Debugger.frmMain.OpenFile(String FilePath) at AutoIt_Debugger.frmMain.ribHomeFileOpen_Click(Object sender, EventArgs e) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Windows.Forms.RibbonItem.onclick(EventArgs e) at System.Windows.Forms.RibbonSensor.SenseMouseUp(MouseEventArgs e) at System.Windows.Forms.RibbonSensor._control_MouseUp(Object sender, MouseEventArgs e) at System.Windows.Forms.Ribbon.onmouseup(MouseEventArgs e) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativewindow.WndProc(Message& m) at System.Windows.Forms.Nativewindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) 
User Information

Sent it to you in email using your email error thing. Happens whenever I open most, if not all of my au3 files :)

-_-------__--_-_-____---_-_--_-__-__-_ ^^€ñ†®øÞÿ ë×阮§ wï†høµ† ƒë@®, wï†høµ† †ïmë, @ñd wï†høµ† @ †ïmïdï†ÿ ƒø® !ïƒë. €×阮 ñø†, bµ† ïñ§†ë@d wï†hïñ, ñ@ÿ, †h®øµghøµ† †hë 맧ëñ§ë øƒ !ïƒë.

Link to post
Share on other sites

I have an error:

Error - Window class name is not valid.

Error Information 
Name Value 
Source System.Windows.Forms 
Message Window class name is not valid. 
TargetSite Void RegisterClass() 
StackTrace at System.Windows.Forms.Nativewindow.WindowClass.RegisterClass() at System.Windows.Forms.Nativewindow.WindowClass.Create(String className, Int32 classStyle) at System.Windows.Forms.Nativewindow.CreateHandle(CreateParams cp) at System.Windows.Forms.Control.CreateHandle() at System.Windows.Forms.Control.get_Handle() at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.SendMessageDirect(UInt32 msg, IntPtr wParam, IntPtr lParam) at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.SendMessageDirect(UInt32 msg, Int32 wParam, Int32 lParam) at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.GetCodePage() at ScintillaNet.Scintilla..ctor(String sciLexerDllName) at AutoIt_Debugger.frmdocument.InitializeComponent() at AutoIt_Debugger.frmdocument..ctor() at AutoIt_Debugger.frmMain.OpenFile(String FilePath) at AutoIt_Debugger.frmMain.ribHomeFileOpen_Click(Object sender, EventArgs e) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Windows.Forms.RibbonItem.onclick(EventArgs e) at System.Windows.Forms.RibbonSensor.SenseMouseUp(MouseEventArgs e) at System.Windows.Forms.RibbonSensor._control_MouseUp(Object sender, MouseEventArgs e) at System.Windows.Forms.Ribbon.onmouseup(MouseEventArgs e) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativewindow.WndProc(Message& m) at System.Windows.Forms.Nativewindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) 
User Information

Sent it to you in email using your email error thing. Happens whenever I open most, if not all of my au3 files :)

I think this is an old problem with SciLexer. Copying Scilexer.dll from the installation folder to the Windows System32 folder should fix this. Give it a try and see.

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...