Jump to content

Graphical AutoIt Debugger


Recommended Posts

@Stumpii

Dont know if it has been reported but when you have OnAutoItExit function in your script and you run it from your debuger, there is duplicate function name error...

Cheers, FireFox.

This is a limitation that I did document somewhere (can't remember where) because the debugger needs to function. I will see if it is something that I can work around, or fix.

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites
  • Replies 430
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Here is the first new issue of the debugger for a long time! Error List: Variables: Tool Chest: Class Viewer: Features: Automatic updates. COM operation replaced with Windows messaging (sc

thanks, this helps alot ^^

My code is: $in = '["1230A1+4560B3B","Inspect door, install knob, replace hinge",False,$K99P2],_' $vec = StringSplit($in,",") local $vec2[ubound($vec)] $i = 0 $j = 0 $saved = "" For $i = 1 to ubound

Posted Images

@Stumpii

Maybe....

Opt("OnExitFunc", "_MyExitFunc")

Cheers, FireFox.

 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Link to post
Share on other sites

New version of the debugger. Refer to first post for link. This version includes the following changes. Thanks everyone for their input.

Stumpii

Rev 0.20.0 - 17 Feb 09

Added: Save prompt when closing a file or program.

Added: New document button on toolbar. Thanks t8inevergreen.

Fixed: Funky action with calltips and autocomplete operation.

Changed: Now allows use of OnAutoItExit function. This function will NOT be debugged. Thanks Firefox.

Changed: Creation of debug file now part of the IDE, not a separate function.

Added: Added support for ConsoleWriteError. Thanks BodoWitcha.

Added: Debug file generator checked to force a recompile on new debugger install. Thank storme.

Edit: If anyone has ideas on an icon for the program, let me know.

Edited by Stumpii

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

with

$a = 1
$b = 1
$c = 1
If $a = $b And _
      $b = $c Then MsgBox(0, '', '$a=$c')

result

---------------------------

AutoIt Error

---------------------------

Line 33 (File "C:\.....\New AutoIt v3 Script (2).Debug Script.au3"):

If $a = $b And AutoIt_Debugger_FinishedLine("C:\Documents and Settings\yO!\Desktop\New AutoIt v3 Script (2).au3", "New AutoIt v3 Script (2).au3", 4, False, @error, @extended)

Error: "If" statements must have a "Then" keyword.

---------------------------

OK

---------------------------

Link to post
Share on other sites

I've had issues with assigning variables in the Dim (or Local) statements with the value from a function. However, I find that it's worth recoding your script a little in order to get the full benefit of the debugger which is fantastic!

My main problem is trying to edit the script in the debugger; it just doesn't work. I have to edit the script in Scite, save it and then reload it in the debugger. A minor annoyance really :)

WBD

Link to post
Share on other sites

Hi, Stumpii

When i use an array like this

Global $ArrayProc[17] = [ _
        "a", "b", "c", "d", "e", "f", "g", "h", _
        "i", "j", "k", "l", "m", "n", "o", "p", "q"]

the debugger generate this error: Posted Image

thanks for your attention

Fixed in v0.21. Thanks, Stumpii

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

with

$a = 1
$b = 1
$c = 1
If $a = $b And _
      $b = $c Then MsgBox(0, '', '$a=$c')

result

---------------------------

AutoIt Error

---------------------------

Line 33 (File "C:\.....\New AutoIt v3 Script (2).Debug Script.au3"):

If $a = $b And AutoIt_Debugger_FinishedLine("C:\Documents and Settings\yO!\Desktop\New AutoIt v3 Script (2).au3", "New AutoIt v3 Script (2).au3", 4, False, @error, @extended)

Error: "If" statements must have a "Then" keyword.

---------------------------

OK

---------------------------

Fixed in v0.21. Thanks, Stumpii

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

I've had issues with assigning variables in the Dim (or Local) statements with the value from a function. However, I find that it's worth recoding your script a little in order to get the full benefit of the debugger which is fantastic!

Give me an example to look at.

My main problem is trying to edit the script in the debugger; it just doesn't work. I have to edit the script in Scite, save it and then reload it in the debugger. A minor annoyance really :)

WBD

Can you be more specific about 'it just doesn't work'? The editing control is based upon the one in SciTE, and though I know it does not work exactly the same, it is pretty close.

Thanks for you input, Stumpii.

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

Stumpii

in version 0.21.0.0, with this code:

If _Singleton(@ScriptName, 1) = 0 Then
    MsgBox(16, "ALERT!!!", "Instance already run.")
    Exit
EndIfoÝ÷ Ú(ZvØb±ê뢹mºè®«¨´IÝ!ú®¢Û-jצz{pØg¢f­r§«¨´êºlµ«^éíÖ§vØb²+0®+^v)íç^,r¸©µ«­¢+ÙÕѽ%Ñ}ÕÉ}9áÑ1¥¹ ÅÕ½ÐíèÀäÈíMÉ¥ÁÑ}ÔÌÀäÈíEÕÉä¹ÔÌÅÕ½Ðì°ÅÕ½ÐíEÕÉä¹ÔÌÅÕ½Ðì°ÌÀ䰱ͰÉɽȰáѹ¤(%M¥¹±Ñ½¸ ÀÌØíQµÁ=É¥¥¹±¥±   ¥¹Õ¥±9µ°Ä¤ôÀQ¡¸%5Í    ½à ÄØ°ÅÕ½Ðí1IPÌÌìÌÌìÌÌìÅÕ½Ðì°ÅÕ½Ðí%¹Íѹ±ÉäÉÕ¸¸ÅÕ½Ðì¤)Õѽ%Ñ}ÕÉ}¥¹¥Í¡1¥¹ ÅÕ½ÐíèÀäÈíMÉ¥ÁÑ}ÔÌÀäÈíEÕÉä¹ÔÌÅÕ½Ðì°ÅÕ½ÐíEÕÉä¹ÔÌÅÕ½Ðì°ÌÄÀ°±Í°ÉɽȰáѹ¤()Õѽ%Ñ}ÕÉ}9áÑ1¥¹ ÅÕ½ÐíèÀäÈíMÉ¥ÁÑ}ÔÌÀäÈíEÕÉä¹ÔÌÅÕ½Ðì°ÅÕ½ÐíEÕÉä¹ÔÌÅÕ½Ðì°ÌÄÄ°±Í°ÉɽȰáѹ¤(%á¥Ð)Õѽ%Ñ}ÕÉ}¥¹¥Í¡1¥¹ ÅÕ½ÐíèÀäÈíMÉ¥ÁÑ}ÔÌÀäÈíEÕÉä¹ÔÌÅÕ½Ðì°ÅÕ½ÐíEÕÉä¹ÔÌÅÕ½Ðì°ÌÄÄ°±Í°ÉɽȰáѹ¤()Õѽ%Ñ}ÕÉ}9áÑ1¥¹ ÅÕ½ÐíèÀäÈíMÉ¥ÁÑ}ÔÌÀäÈíEÕÉä¹ÔÌÅÕ½Ðì°ÅÕ½ÐíEÕÉä¹ÔÌÅÕ½Ðì°ÌÄÈ°±Í°ÉɽȰáѹ¤()¹%)Õѽ%Ñ}ÕÉ}¥¹¥Í¡1¥¹ ÅÕ½ÐíèÀäÈíMÉ¥ÁÑ}ÔÌÀäÈíEÕÉä¹ÔÌÅÕ½Ðì°ÅÕ½ÐíEÕÉä¹ÔÌÅÕ½Ðì°ÌÄÈ°±Í°ÉɽȰáѹ¤()Õѽ%Ñ}ÕÉ}9áÑ1¥¹ ÅÕ½ÐíèÀäÈíMÉ¥ÁÑ}ÔÌÀäÈíEÕÉä¹ÔÌÅÕ½Ðì°ÅÕ½ÐíEÕÉä¹ÔÌÅÕ½Ðì°ÌÄÌ°±Í°ÉɽȰáѹ¤

thanks

Link to post
Share on other sites

Give me an example to look at.

Sorry. It only happened once and I don't remember the exact details. However, I did have to edit the script in order for it to work properly.

Can you be more specific about 'it just doesn't work'? The editing control is based upon the one in SciTE, and though I know it does not work exactly the same, it is pretty close.

When I start to type, the list of keyword suggestions pops up. If I ignore it and carry on typing then the text that I had typed disappears. Happens every time. I have a screen recording of it which I've temporarily uploaded here:

Hope this helps.

WBD

Link to post
Share on other sites

New version 0.22:

Includes:

Fixed: More problems with continuation lines. Thanks nkono.

Added: Running Debugger with no command line args automatically opens a new document.

Fixed: Skipping of Select statements.

Added: Tool Chest. Double click on a function to insert it into the active script.

Added: Option to disable AutoComplete (in options dialog).

@nkono - This should fix problems with _Singleton

@Peppe - This should fix the problem with your script. Forum link is now right (though I lost all the forum data!)

@WideBoxDixon - Autocomplete is one pain the butt bit of code. I have added a disable option in the option form until this works completely.

One new feature add with is a Tool Chest, basically a list of Include, macros and Functions that can be added to the script by double clicking on an item. Here is a screenshot of the ToolChest:

post-6932-1235448413_thumb.png

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

Anything works fine after unistall/reinstall of the debugger

Everything works fine, or nothing works fine?

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Link to post
Share on other sites

Yea, I had the same problem. After trying that RibbonButton under the Work In Progress menu, it pretty much crashed the debugger no matter what I did until I reinstalled and blew away my data files.

Now I reinstalled it and it doesn't crash. But it also doesn't really work. I used to use v19 and that worked great. Now I upgraded and I click RUN, and sometimes it does stuff, and other times it just flickers the screen and does nothing.

It shows an active running copy in the task tray area, but it doesn't load the program or even reach the first breakpoint.

So then I tried v21. But that keeps giving me some error on line 700, "Endif without if". But my code only goes to line 300 and I double checked, there are no mismatches.

Now I'm back to v20 and its working.

Let me know if you need any logs or anything to help.

Edited by DssTrainer
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...