Sign in to follow this  
Followers 0
philo

Need Help Please

7 posts in this topic

Hi, this is my script:

#include <IE.au3>

$o_IE = _IECreate ()
_IENavigate ($o_IE, "http://www.crimeclub.nl/login.php")


; get pointers to the login form and username and password fields
$o_form = _IETableGetObjByIndex($o_IE, 0)
$o_login = _IEFormElementGetObjByName($o_form, "login")
$o_password = _IEFormElementGetObjByName($o_form, "pass")

; Set field values and submit the form
_IEFormElementSetValue($o_login, "test")
_IEFormElementSetValue($o_password, "test")
_IEFormSubmit($o_form)

Exit

I get this error

Posted Image

Does somebody know what to do?

THx


Auto It Ruels

Share this post


Link to post
Share on other sites



Are you running with beta version.



Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

Are you running with beta version.

I know I am, and get the same error, but then I haven't used the IE.au3 include very much.


SciTE for AutoItDirections for Submitting Standard UDFs

 

Don't argue with an idiot; people watching may not be able to tell the difference.

 

Share this post


Link to post
Share on other sites

Yep this one: autoit-v3.1.1.114-beta-Setup.exe


Auto It Ruels

Share this post


Link to post
Share on other sites

$o_form = _IETableGetObjByIndex($o_IE, 0)

$o_login = _IEFormElementGetObjByName($o_form, "login")

$o_form = _IETableGetObjByIndex($o_IE, 0)

Try

$o_form = _IEFormGetObjByIndex($o_IE, 0)

:)

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Works , thx alot DaleHohm .

Compliment for the IE.au3 script :)


Auto It Ruels

Share this post


Link to post
Share on other sites

:| NOOO HOW COUlD I MISS THAT XD

(i tryed to fix the script before he posted)

DOH DOH DOH, now i look like Vali.... nvm


*If u thought life couldn't get worse, u meet me *<guy> What would you give my little sister to unzip ?<friend> 10 bucks<guy> No, i mean like Winzip...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0