Sign in to follow this  
Followers 0
The Kandie Man

4096 Gui Controls Per Window

18 posts in this topic

Anyway, the title says it all. I was just wondering why AutoIt has a limit of 4096 controls per window and if there is a chance that this limitation could be changed.


"So man has sown the wind and reaped the world. Perhaps in the next few hours there will no remembrance of the past and no hope for the future that might have been." & _"All the works of man will be consumed in the great fire after which he was created." & _"And if there is a future for man, insensitive as he is, proud and defiant in his pursuit of power, let him resolve to live it lovingly, for he knows well how to do so." & _"Then he may say once more, 'Truly the light is sweet, and what a pleasant thing it is for the eyes to see the sun.'" - The Day the Earth Caught Fire

Share this post


Link to post
Share on other sites



Are you running into the 4096 limit?

Share this post


Link to post
Share on other sites

I'm curious if you are running into a 4096 limit... what in the world kind of GUI you've made... I can't imagine that many controls :)


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

I'm curious if you are running into a 4096 limit... what in the world kind of GUI you've made... I can't imagine that many controls :)

I got up to about 2100 on my Sudoku Solver, so I'm about halfway there. I could definitely see a listview getting that large (for example a file-searching engine listing out every picture or something).

Share this post


Link to post
Share on other sites

Nice find :)

I'm curious if you are running into a 4096 limit... what in the world kind of GUI you've made... I can't imagine that many controls :mellow:

It's conceivable with ListView and Tree view since EACH List/TreeItem counts as one control....

Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Yup, i am running into the limit big time. My Search Engine creates a list view item for every search result. If there is over 4000 search results the ones over 4000 are simply not displayed. If you would like to see it you can find it here:

http://www.autoitscript.com/forum/index.php?showtopic=23815

Edited by The Kandie Man

"So man has sown the wind and reaped the world. Perhaps in the next few hours there will no remembrance of the past and no hope for the future that might have been." & _"All the works of man will be consumed in the great fire after which he was created." & _"And if there is a future for man, insensitive as he is, proud and defiant in his pursuit of power, let him resolve to live it lovingly, for he knows well how to do so." & _"Then he may say once more, 'Truly the light is sweet, and what a pleasant thing it is for the eyes to see the sun.'" - The Day the Earth Caught Fire

Share this post


Link to post
Share on other sites

Yup, i am running into the limit big time. My Search Engine creates a list view item for every search result. If there is over 4000 search results the ones over 4000 are simply not displayed. If you would like to see it you can find it here:

http://www.autoitscript.com/forum/index.php?showtopic=23815

Just a thought. You probably to make your list view viritual. When the user scrols you have to keep track of it and update the list view. Google for samples in VB code doing just that (through API call's).

Share this post


Link to post
Share on other sites

Thanks i didn't know about that but i would rather try my best to stick with native AutoIt functions if possible. I want to make this program as portable as possible and having it lug a bunch of dll and other libraries with it defeats the point. I will give it a try if there is no other alternative though. :)


"So man has sown the wind and reaped the world. Perhaps in the next few hours there will no remembrance of the past and no hope for the future that might have been." & _"All the works of man will be consumed in the great fire after which he was created." & _"And if there is a future for man, insensitive as he is, proud and defiant in his pursuit of power, let him resolve to live it lovingly, for he knows well how to do so." & _"Then he may say once more, 'Truly the light is sweet, and what a pleasant thing it is for the eyes to see the sun.'" - The Day the Earth Caught Fire

Share this post


Link to post
Share on other sites

I downloaded it. I think it may be what i am looking for, but i keep getting errors when i run it.

Autoit3Ex.au3 (23) : ==> Can not redeclare a constant.: 
Global Const $TVM_INSERTITEM            = $TV_FIRST + 0 
Global Const ^ ERROR

"So man has sown the wind and reaped the world. Perhaps in the next few hours there will no remembrance of the past and no hope for the future that might have been." & _"All the works of man will be consumed in the great fire after which he was created." & _"And if there is a future for man, insensitive as he is, proud and defiant in his pursuit of power, let him resolve to live it lovingly, for he knows well how to do so." & _"Then he may say once more, 'Truly the light is sweet, and what a pleasant thing it is for the eyes to see the sun.'" - The Day the Earth Caught Fire

Share this post


Link to post
Share on other sites

Hi,

Autoit3Ex.au3 (23) : ==> Can not redeclare a constant.:

Global Const $TVM_INSERTITEM = $TV_FIRST + 0

Global Const ^ ERROR

I can reproduce that in beta 116, but it is OK still in 114!

Go figure...

Is this what happens to you too?

Best, Randall

Share this post


Link to post
Share on other sites

Yup, that is what was happening. The version 114 is working but the newer 116 isn't. Does anyone know why the newer beta version is erroring out?


"So man has sown the wind and reaped the world. Perhaps in the next few hours there will no remembrance of the past and no hope for the future that might have been." & _"All the works of man will be consumed in the great fire after which he was created." & _"And if there is a future for man, insensitive as he is, proud and defiant in his pursuit of power, let him resolve to live it lovingly, for he knows well how to do so." & _"Then he may say once more, 'Truly the light is sweet, and what a pleasant thing it is for the eyes to see the sun.'" - The Day the Earth Caught Fire

Share this post


Link to post
Share on other sites

Yup, that is what was happening. The version 114 is working but the newer 116 isn't. Does anyone know why the newer beta version is erroring out?

I don't know what is wrong with your setup of AutoIt beta and Scite, but on mine it is working as a charm.

You must see the au3check version equal to 1.54.1.1

>Running AU3Check (1.54.1.1)  params:  from:F:\Program Files\AutoIt3\beta
+>AU3Check ended.rc:0
>Running:(3.1.1.116):F:\Program Files\AutoIt3\beta\autoit3.exe "F:\Documents and Settings\Administrator\Desktop\SearchEngine\src\search engine 1.5.1.9b10.au3"

When you report problem don't forget this version line.

you need to check too the version of GUIListview.au3 (1st line ot it)

Share this post


Link to post
Share on other sites

#16 ·  Posted (edited)

Hi,

I tried a clean install.

1. autoit3 3.1.1 production.

2. Scite4AutoIt

3. beta 116 (others OK at least to 114

i get all sorts of errors ;;

Example with this one;

>"C:\Program Files\AutoIt3\SciTe\CompileAU3\CompileAU3.exe" /run /beta /ErrorStdOut /in "C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3" /autoit3dir "C:\Program Files\AutoIt3\beta" /UserParams

>Running AU3Check (1.54.1.1) params: from:C:\Program Files\AutoIt3\beta

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(23,47) : ERROR: $TVM_INSERTITEM previously declared as a 'Const'

Global Const $TVM_INSERTITEM = $TV_FIRST + 0

~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(25,49) : ERROR: $TVM_SETIMAGELIST previously declared as a 'Const'

Global Const $TVM_SETIMAGELIST = $TV_FIRST + 9

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(26,46) : ERROR: $TVM_SETITEM previously declared as a 'Const'

Global Const $TVM_SETITEM = $TV_FIRST + 13

~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(28,41) : ERROR: $TVI_FIRST previously declared as a 'Const'

Global Const $TVI_FIRST = 0xFFFF0001

~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(30,37) : ERROR: $TVIF_IMAGE previously declared as a 'Const'

Global Const $TVIF_IMAGE = 0x0002

~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(31,38) : ERROR: $TVIF_HANDLE previously declared as a 'Const'

Global Const $TVIF_HANDLE = 0x0010

~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(32,43) : ERROR: $TVIF_SELECTEDIMAGE previously declared as a 'Const'

Global Const $TVIF_SELECTEDIMAGE = 0x0020

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(33,40) : ERROR: $TVIF_CHILDREN previously declared as a 'Const'

Global Const $TVIF_CHILDREN = 0x0040

~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(35,36) : ERROR: $TVIS_CUT previously declared as a 'Const'

Global Const $TVIS_CUT = 0x0004

~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(36,42) : ERROR: $TVIS_DROPHILITED previously declared as a 'Const'

Global Const $TVIS_DROPHILITED = 0x0008

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(37,37) : ERROR: $TVIS_BOLD previously declared as a 'Const'

Global Const $TVIS_BOLD = 0x0010

~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(38,40) : ERROR: $TVIS_EXPANDED previously declared as a 'Const'

Global Const $TVIS_EXPANDED = 0x0020

~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(40,37) : ERROR: $TVGN_ROOT previously declared as a 'Const'

Global Const $TVGN_ROOT = 0x0000

~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3 - 13 error(s), 0 warning(s)

!>AU3Check ended.rc:2

>Exit code: 0 Time: 19.970

What am I doing wrong with a clean install?

Have you tried this?

Best, Randall.

PS

C:\Program Files\AutoIt3\beta\Include\GUIListView

; Include Version:1.56 (3/14/2006)

Edit; I have got the Scite version right now; edited above; so all versions look correct? n'est-ce pas? Edited by randallc

Share this post


Link to post
Share on other sites

#17 ·  Posted (edited)

are you installing with the setup.exe or with the .zip?

the only difference I can see is I do

1. 3.1.1

2. 3.1.1.116

3. Scite

4. Scite update

edit:all with setup.exe

That's a question for JdeB I cannot really answer of what can be wrong with what you are doing :):mellow:

Edited by jpm

Share this post


Link to post
Share on other sites

#18 ·  Posted (edited)

"C:\Program Files\AutoIt3\SciTe\CompileAU3\CompileAU3.exe" /run /beta /ErrorStdOut /in "C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3" /autoit3dir "C:\Program Files\AutoIt3\beta" /UserParams

>Running AU3Check (1.54.1.1) params: from:C:\Program Files\AutoIt3\beta

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(23,47) : ERROR: $TVM_INSERTITEM previously declared as a 'Const'

Global Const $TVM_INSERTITEM = $TV_FIRST + 0

~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(25,49) : ERROR: $TVM_SETIMAGELIST previously declared as a 'Const'

Global Const $TVM_SETIMAGELIST = $TV_FIRST + 9

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(26,46) : ERROR: $TVM_SETITEM previously declared as a 'Const'

Global Const $TVM_SETITEM = $TV_FIRST + 13

~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(28,41) : ERROR: $TVI_FIRST previously declared as a 'Const'

Global Const $TVI_FIRST = 0xFFFF0001

~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(30,37) : ERROR: $TVIF_IMAGE previously declared as a 'Const'

Global Const $TVIF_IMAGE = 0x0002

~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(31,38) : ERROR: $TVIF_HANDLE previously declared as a 'Const'

Global Const $TVIF_HANDLE = 0x0010

~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(32,43) : ERROR: $TVIF_SELECTEDIMAGE previously declared as a 'Const'

Global Const $TVIF_SELECTEDIMAGE = 0x0020

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(33,40) : ERROR: $TVIF_CHILDREN previously declared as a 'Const'

Global Const $TVIF_CHILDREN = 0x0040

~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(35,36) : ERROR: $TVIS_CUT previously declared as a 'Const'

Global Const $TVIS_CUT = 0x0004

~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(36,42) : ERROR: $TVIS_DROPHILITED previously declared as a 'Const'

Global Const $TVIS_DROPHILITED = 0x0008

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(37,37) : ERROR: $TVIS_BOLD previously declared as a 'Const'

Global Const $TVIS_BOLD = 0x0010

~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(38,40) : ERROR: $TVIS_EXPANDED previously declared as a 'Const'

Global Const $TVIS_EXPANDED = 0x0020

~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3(40,37) : ERROR: $TVGN_ROOT previously declared as a 'Const'

Global Const $TVGN_ROOT = 0x0000

~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~^

C:\Program Files\AU3PROGS\SearchEngine\Autoit3Ex.au3 - 13 error(s), 0 warning(s)

!>AU3Check ended.rc:2

>Exit code: 0 Time: 19.970

Hi randllac,

I have the same errors when I used the latest beta 116, I also notice that GUITreeView.au3 was updated and alredy include all those varibables. Once you remark those line your script work fine.

Edit: This is the link about the new updates

Edited by Danny35d

AutoIt Scripts:NetPrinter - Network Printer UtilityRobocopyGUI - GUI interface for M$ robocopy command line

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0