Sign in to follow this  
Followers 0
Jos

New SciTE4AutoIt3 with SciTE v1.69

28 posts in this topic

#1 ·  Posted (edited)

6/2/2006: Uploaded a new SciTe4AutoIt3.exe installer which contains the new SciTE 1.69 released a few days ago.

Neil released a new version with mainly bug fixes in this new SciTE release, but one nice thing is that when opening an example from the Helpfile, you now can run it without getting the save prompt.

Happy Scripting :D

==> ScitillaHistory page containing all SciTE/Scintilla updates.

==> Visit the SciTe4AutoIt3 Download page for the latest versions

==> Check the online documentation for an overview of all extra's you get with this installer.

Enjoy,

Updates:

6/2/2006
*** Updated installer with SciTE v1.69.
*** Updated Beta definitions to AutoIt3 v 3.1.1.125.
*** Updated AutoIt3Wrapper v1.6 (JdeB)
Added Check for valid Output-path to avoid aut2exe errors.
*** Updated Tidy v1.31.5 (JdeB)
- Fixed: Bug which removed in some occasions the space before the continuation character.
It will now also add a space when the it is missing in before the continuation character.
- Added tidy logic for [], removing the spaces around them.
*** Updated SciTEConfig v1.6 (Mhz)
- Added Tab which allows you to en-/disable Tool menu items.
*** Updated Code Snippet v1.0.4.4 (gafrost)
*** Updated Abbreviations file. (MHz)
Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Great job! Going to downloading the new version now.

Edited by big_daddy

Share this post


Link to post
Share on other sites

Is the AutoIt3Wrapper source the one used to compile Autoit3Wrapper in this release?

Opening the source I found that

$VERSION = "1.4.3.44"

The information provided in this thread about F5 and scite made me wonder if I could seperate the Autoit directory and SciTe directory. But Autoit3Wrapper is not playing along so I thought Id take a look at the source, since it is there :D

Share this post


Link to post
Share on other sites

Is the AutoIt3Wrapper source the one used to compile Autoit3Wrapper in this release?

Opening the source I found that

$VERSION = "1.4.3.44"

The information provided in this thread about F5 and scite made me wonder if I could seperate the Autoit directory and SciTe directory. But Autoit3Wrapper is not playing along so I thought Id take a look at the source, since it is there :D

That statement is a mistake and should have been take out when i put these in it in the lines before it.:

Global $VERSION = FileGetVersion(@ScriptFullPath)
$VERSION = StringLeft($VERSION, StringInStr($VERSION, ".", 0, -2) - 1)

SciTE can be installed in a seperate directory, it not recommended but possible. SciTE uses the autoitdir3= parameter from the au3.properties file which is set by the UpdateDefs.exe program ran at the end of the installer process ... or you can run in manually.


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Ok, thanks.

The reason I would like to split out scite is that I will use it for other programming environments as well. But I can really see, and appreciate, the benefits of todays structure for the entry level (and occasional) programmer.

Thanks for your good work, keep it up :D

Share this post


Link to post
Share on other sites

Thanks for your efforts on this...


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Try this new version on this script in first page :

http://www.autoitscript.com/forum/index.ph...opic=24678&st=0

then you will get this errors when you try to compile :

C:\Temp\clock.au3(138,50) : ERROR: TrayItemSetOnEvent(): undefined function.
TrayItemSetOnEvent ($TrayItemMove, "MoveTheClock")
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\Temp\clock.au3(150,52) : ERROR: TrayItemSetState(): undefined function.
TrayItemSetState ($TrayItemAlarmTime, $TRAY_DISABLE)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\Temp\clock.au3(153,87) : ERROR: TrayItemSetText(): undefined function.
    $AlarmTime[3] & " on " & $AlarmTime[4] & "/" & $AlarmTime[5] & "/" & $AlarmTime[6])
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\Temp\clock.au3(488,65) : ERROR: GUICtrlCreateMonthCal(): undefined function.
    $GUI_Alarm_Cal = GUICtrlCreateMonthCal ("", 10, 77, 200, 165)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\Temp\clock.au3(561,23) : ERROR: Beep(): undefined function.
        Beep (400, 500)
~~~~~~~~~~~~~~~~~~~~~~^
C:\Temp\clock.au3 - 5 error(s), 0 warning(s)
Edited by FeReNGi

Share this post


Link to post
Share on other sites

FeReNGi,

The member who posted that script failed to mention that it requires the Beta version of AutoIt :D . Alas, happens often.

The error output shown above does not show the important line of which Au3Check definitions are being used. Since I get no errors with beta definitions and 5 errors with production definitions, then I can only state that you are using the wrong definitions. Use the beta actions instead.

If I was given a small donation for everytime a incorrect version report happens, I would be super wealthy now :D .

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

@ JDeB

Little cosmetics:

with latest Scite (1.69 6/2/2006) and latest beta of AutoIt (126):

#forceref is not highlighted like other #xx keywords

And idea: Maybe Scite4AutoIt3 could have its own version

and not only derived from Scite version and date.

EDIT: also Switch EndSwitch is not highlighted

Edited by Zedna

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

Little cosmetics:

with latest Scite (1.69 6/2/2006) and latest beta of AutoIt (126):

#forceref is not highlighted like other #xx keywords

Will be added in the next update

EDIT: also Switch EndSwitch is not highlighted

Not for me... maybe you don't have the Beta defs loaded ?

And idea: Maybe Scite4AutoIt3 could have its own version

and not only derived from Scite version and date.

I like the SciTE version plus Date because there is no program that would get the version number i assign to it.... so a Date for the installer has more meaning ....

Thanks for your feedback...

Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

Hi JDeB

What about adding to Scite4AutoIt3 support also for AUT scripts from AutoIt 2.64?

I'm still using AutoIt 2.64 for very simple scripts for instalation/logg-on/load of some files etc.

As there is very simple script and very small output EXE (43 KB).

I'm not familiar with configuring Scite, but if you can provide me some basics about

what files should be added/changed, I can do it myself.

Advantage is, that v 2.64 is not changing anymore, so this could be done only once

without any future updates.

My idea is:

- add support for highlight of AUT extension (based on AutoIt version 2.64)

- for this type of file have in menu Tools these command:

F5 - Run

F7 - Build

F1 - Help

maybe also: AutoIt reveal, Open include

Maybe AutoIt (2.64) instal dir can be set for simplicity to fixed path "C:\Program Files\AutoIt"

As I said, I can create some analoque au3.api --> aut.api file if you help me with integrating this to Scite.

What do you mean?

Edited by Zedna

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

Hi JDeB

What about adding to Scite4AutoIt3 support also for AUT scripts from AutoIt 2.64?

I'm still using AutoIt 2.64 for very simple scripts for instalation/logg-on/load of some files etc.

As there is very simple script and very small output EXE (43 KB).

I'm not familiar with configuring Scite, but if you can provide me some basics about

what files should be added/changed, I can do it myself.

Advantage is, that v 2.64 is not changing anymore, so this could be done only once

without any future updates.

My idea is:

- add support for highlight of AUT extension (based on AutoIt version 2.64)

- for this type of file have in menu Tools these command:

F5 - Run

F7 - Build

F1 - Help

maybe also: AutoIt reveal, Open include

Maybe AutoIt (2.64) instal dir can be set for simplicity to fixed path "C:\Program Files\AutoIt"

As I said, I can create some analoque au3.api --> aut.api file if you help me with integrating this to Scite.

What do you mean?

Attach the aut.properties which will give you basic support for aut. the other 2 files are also required!

just copy the 3 files into your SciTE directory and update the below line in aut.properties to point to your v2 directory:

autoit2dir=C:\Program Files\AutoIt2

:D

Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

Attach the aut.properties which will give you basic support for aut. the other 2 files are also required!

just copy the 3 files into your SciTE directory and update the below line in aut.properties to point to your v2 directory:

autoit2dir=C:\Program Files\AutoIt2

All you need to do is to create the aut.api file ...... :D

Hey man, thanks very much :D

I will try it and will post here that api file, when it will be done.

EDIT: this api file is in ZIP already! THANKS twice :P

EDIT2: I can finish this api file - parametres and description and some keywords

Edited by Zedna

Share this post


Link to post
Share on other sites

#14 ·  Posted (edited)

Attach the aut.properties which will give you basic support for aut. the other 2 files are also required!

just copy the 3 files into your SciTE directory and update the below line in aut.properties to point to your v2 directory:

autoit2dir=C:\Program Files\AutoIt2

:D

First quick look:

There is missing F1 - Help in Tools menu.

I looked into aut.properties and observed this error:

command.help.$(file.patterns.aut)=$(autoit2dir)\autoit.chm

should be

command.help.$(file.patterns.aut)="$(autoit2dir)\autoit.chm"

but after taht correction it still doesn't work for me.

Edited by Zedna

Share this post


Link to post
Share on other sites

#15 ·  Posted (edited)

I have not looked at the files but do you find something like autoit2dir= anywhere?

You probably have to point it at your aut directory.

au3.properties has it's equivalent at the top of the file. $(variablename) expands the variable.

I have placed my definitions in sciteglobal.properties.

EDIT: You can also use relative references to your scite directory:

autoit2dir=$(SciteDefaultHome)\..\autoit-v2
Edited by Uten

Share this post


Link to post
Share on other sites

#16 ·  Posted (edited)

I have not looked at the files but do you find something like autoit2dir= anywhere?

You probably have to point it at your aut directory.

au3.properties has it's equivalent at the top of the file. $(variablename) expands the variable.

I have placed my definitions in sciteglobal.properties.

EDIT: You can also use relative references to your scite directory:

autoit2dir=$(SciteDefaultHome)\..\autoit-v2
Of course, first of all I corrected in aut.properties autoit2dir=C:\Program Files\AutoIt

F5 and F7 is working fine. Only F1 - Help is not working and is not in menu Tools.

EDIT: when F1 will be working I'm thinking about create AutoITHelp.exe for opening HelpFile at exact topic dependending on current word in Scite. I have already some ideas how to do it...

Edited by Zedna

Share this post


Link to post
Share on other sites

Of course, first of all I corrected in aut.properties autoit2dir=C:\Program Files\AutoIt

F5 and F7 is working fine. Only F1 - Help is not working and is not in menu Tools.

EDIT: when F1 will be working I'm thinking about create AutoITHelp.exe for opening HelpFile at exact topic dependending on current word in Scite. I have already some ideas how to do it...

This can only be done when the Helpfile is updated with an INDEX.

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

This can only be done when the Helpfile is updated with an INDEX.

I googled some HtmlHelp API and for example here:

VB code using DllCall through "hhctrl.ocx"

This is VB code for invoking CHM at certain topic based on name of HTML file in CHM.

So there can be used anchors defined for every AutoIt keyword: <a name="IfWinExist">

AutoIt.chm::/Files/Script_Commands.htm#Exit

In AutoItHelp.au3 (exe) I can handle situations when more than one keyword has same adress/anchor

like IfWinExist/IfWinNotExist /IfWinActive/IfWinNotActive

Share this post


Link to post
Share on other sites

try attached version :D

This is better but not best :D

F1 is working, but in menu Tools it is still missing

I don't understand that subsystem stuff (where are these subsystems defined):

command.help.subsystem.$(file.patterns.aut)=2

and where is defined that F1 hotkey which is working?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0