Jump to content
Sign in to follow this  
Rraney

Problems using character class functions with StringRegExp

Recommended Posts

Rraney

Is it just me (to be honest It would not surprise me!) or is there a problem using character class types in AutoIt's StringRegExp function. IE /r /w /s /W

I have included some example code, and it looks strange but It does work in Python, Perl, and a few other places I have checked.

;example code
#Include <Array.au3>

dim $_tmp
dim $_a
;              these are tab's BTW....  
$_a = "                                        This is a Test" & @CRLF
$_tmp1 =StringRegExp($_a , '[^a-zA-Z0-9 ]+(.+)\r$', 3)



; we should have array display pop up if $_tmp is an array!
_ArrayDisplay($_tmp, "We have:")
Edited by Rraney

Share this post


Link to post
Share on other sites
i542

Please include bigger code, my AutoIt is only closed....


I can do signature me.

Share this post


Link to post
Share on other sites
marfdaman

Please include bigger code, my AutoIt is only closed....

There's no need to do that, just use a msgbox to view the result.


Don't take my pic to serious...~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~You Looked, but you did not see!~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites
Rraney

Code changed.

Please include bigger code, my AutoIt is only closed....

Share this post


Link to post
Share on other sites
Rraney

Code changed.

oops, code changed again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×