Sign in to follow this  
Followers 0
AzKay

Eh, this error is pissing me off.

11 posts in this topic

#1 ·  Posted (edited)

AutiIt Error

Line 289 (File"C:\Program Files\Autoit3\beta\Include\IE.au3

Case "0"

Error: "Case" Statement with no matching "Select" statement.

I keep getting that. Very annoying. need my script?

; ----------------------------------------------------------------------------
;
; AutoIt Version: 3.1.0
; Author:         Azkay <azkay.s@gmail.com>
;
; Script Function: GaiaOnline MultiBot
;
; Credits: AutoIt Support Forum - Helping me out lots ~
;                 goflago - Helping me out too ;) ~
; ----------------------------------------------------------------------------

#include <IE.au3>

HotKeySet("^!1", "_IniGet")
HotKeySet("^!2", "_Post")
HotKeySet("^!3", "_Poll")
HotKeySet("^!4", "_Art_Arena")
HotKeySet("^!5", "_Refresher")
HotKeySet("^!6", "_ToggleHide")
HotKeySet("^!7", "_Exit")

If FileExists("MultiBotReadMe.txt") Then 
        
        TrayTip("", "Yay For Azkay, Yay For Ashwing, Yay For All", 5)
        Sleep( 2500 )
        TrayTip("", "", 0)
    
    Else

FileOpen("MultiBotReadMe.txt", 1)
    FileWriteLine("MultiBotReadMe.txt", "Gaia Online MultiBot BETA.")
    FileWriteLine("MultiBotReadMe.txt", "===============================================================")
    FileWriteLine("MultiBotReadMe.txt", "Author:         Azkay <azkay.s@gmail.com>")
    FileWriteLine("MultiBotReadMe.txt", "Function:       GaiaOnline MultiBot")
    FileWriteLine("MultiBotReadMe.txt", "Credits:        AutoIt Support Forum - Helping me out lots ~")
    FileWriteLine("MultiBotReadMe.txt", "            goflago - Helping me out too ;) ~")
    FileWriteLine("MultiBotReadMe.txt", "===============================================================")
    FileWriteLine("MultiBotReadMe.txt", "NOTE :: Before running the program, go to the login screen ( Using IE ) and login using the ""Remember Me"" option.")
    FileWriteLine("MultiBotReadMe.txt", "NOTE :: Run the program then press CTRL + ALT + 1, Once you see the TrayTip, exit the program, and configure the INI.")
    FileWriteLine("MultiBotReadMe.txt", "Ctrl + Alt + 1 = Gets you the Config File.")
    FileWriteLine("MultiBotReadMe.txt", "Ctrl + Alt + 2 = Starts Auto Posting.")
    FileWriteLine("MultiBotReadMe.txt", "Ctrl + Alt + 3 = Starts Auto Polling = Not Implimented.")
    FileWriteLine("MultiBotReadMe.txt", "Ctrl + Alt + 4 = Starts Auto Arena Voting.")
    FileWriteLine("MultiBotReadMe.txt", "Ctrl + Alt + 4 = Starts Refresher.")
    FileWriteLine("MultiBotReadMe.txt", "Ctrl + Alt + 6 = Toggles Window Hiding = Not Implimented.")
    FileWriteLine("MultiBotReadMe.txt", "Ctrl + Alt + 7 = Exits the Program.")
    FileWriteLine("MultiBotReadMe.txt", "===============================================================")
    FileWriteLine("MultiBotReadMe.txt", "THIS IS MY PROGRAM, I MADE IT, SO DONT GO SAYING YOU MADE IT")
FileClose("MultiBotReadMe.txt")

        TrayTip("", "Dont Forget To Read The Readme", 5, 1)
        Sleep( 2500 )
        TrayTip("", "", 0)
EndIf

While 1
    Sleep(20)
WEnd

Func _IniGet()
    If FileExists("Multibot.ini") Then 
        
        MsgBox(0, "", "Pressing OK will reset your current .ini, are you sure you want to continue?")
    
    Else
    
    ; _Post INI
    IniWrite ( "MultiBot.ini", "PostThread", "Url", "Url to thread")
    IniWrite ( "MultiBot.ini", "Reply", "Url", "Url to ""Reply"" Image")
    IniWrite ( "MultiBot.ini", "Message", "MessageBody", "Message body goes here")
    ; _Poll INI
    IniWrite ( "MultiBot.ini", "PollThread", "Url", "Url to thread")
    IniWrite ( "MultiBot.ini", "Edit", "Url", "Url to ""Edit"" Image")
    ; _Art_Arena INI
    IniWrite ( "MultiBot.ini", "ArenaPage", "Url", "Url to Avatar Arena main page")
    IniWrite ( "MultiBot.ini", "ArenaPageTitle", "Title", "Page title AFTER Gaia :: But BEFORE the - Microsoft Internet Explorer")
    IniWrite ( "MultiBot.ini", "Vote", "Url", "Url of the image of the number you want to autovote for each image")
    ; _Refresher INI
    IniWrite ( "MultiBot.ini", "RefreshPage", "Url", "Url to page to refresh on")
    IniWrite ( "MultiBot.ini", "RefreshPageTitle", "Title", "Page title AFTER Gaia :: But BEFORE the - Microsoft Internet Explorer")
    IniWrite ( "MultiBot.ini", "RefreshEvery", "Interval", "Interval between refresh here")
    
        TrayTip ("", "INI Created.", 5, 1)
        Sleep( 2500 )
        TrayTip("", "", 0)
EndIF
EndFunc

Func _Post()
        $oIE_Post = _IECreate( IniRead( "MultiBot.ini", "PostThread", "Url", ""))
    While 1
        _IEImgClick ( $oIE_Post, IniRead( "MultiBot.ini", "Reply", "Url", ""))
        _IENavigate ( $oIE_Post, "java script:emoticon('" & Iniread( "MultiBot.ini", "Message", "MessageBody", "") & "')", 0)
        $Post = _IEFormGetObjByName($oIE_Post,"post")
        _IEFormImageClick ($Post,"Submit","alt")
        Sleep( 50000 )
    WEnd
EndFunc

Func _Poll()
        TrayTip("", "Coming Soon.", 5, 1)
        Sleep( 2500 )
        TrayTip("", "", 0)
EndFunc

Func _Art_Arena()
$oIE_Art_Arena = _IECreate( IniRead( "MultiBot.ini", "ArenaPage", "Url", ""))

While 1
    _IEImgClick ( $oIE_Art_Arena, Iniread( "MultiBot.ini", "Vote", "Url", ""))
    _IELoadWait ( $oIE_Art_Arena )
WEnd
EndFunc

Func _Refresher()
$oIE_Refresher = _IECreate( IniRead( "MultiBot.ini", "RefreshPage", "Url", ""))

While 1
    ControlSend("Gaia :: " & IniRead( "MultiBot.ini", "RefreshPageTitle", "Title", "") & " - Microsoft Internet Explorer", "", "", "{F5}")
    Sleep( IniRead( "Multibot.ini", "RefreshEvery", "Interval", ""))
WEnd
EndFunc

Func _ToggleHide()
        TrayTip ("", "Coming Soon.", 5, 1)
        Sleep( 2500 )
        TrayTip("", "", 0)
EndFunc

;Func _HideUnHide($s_Title, $s_Text = "")
;    $state = WinGetState($s_Title, $s_Text)
;    If BitAND($state, 2) Then
;        WinSetState($s_Title, $s_Text, @SW_HIDE)
;    Else
;        WinSetState($s_Title, $s_Text, @SW_SHOW)
;    EndIf
;EndFunc

Func _Exit()
    Exit
EndFunc
Edited by AzKay

# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites



[offtopic]

You have linux? lucky....

[/offtopic]

Share this post


Link to post
Share on other sites

No I dont oO


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

looks like it

Share this post


Link to post
Share on other sites

You mean, because of teh black bar? thats just a windows skin, ive got windows blinds running


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

ooooooooooo

Share this post


Link to post
Share on other sites

Hmmm *Wonders why there hasnt been much help happening today*


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

ooooooooooo

ROFL! Spamillia!

:D

Edited by goflago

Share this post


Link to post
Share on other sites

ROFL! Spamillia!

:D

Lookeh, your in credits ^^

# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

Step1: Check that you are using Beta.

Step2: Check that you have a valid copy of IE.au3 (replace the copy on your harddisk with the latest copy, for example.)

Step3: Ask if none of the above works.

#)

Share this post


Link to post
Share on other sites

Looks like you arent running BETA


AutoIt Scripts:Aimbot: Proof of Concept - PixelSearching Aimbot with several search/autoshoot/lock-on techniques.Sliding Toolbar - Add a nice Sliding Toolbar to your next script. Click the link to see an animation of it in action!FontInfo UDF - Get list of system fonts, or search to see if a particular font is installed.Get Extended Property UDF - Retrieve a files extended properties (e.g., video/image dimensions, file version, bitrate of song/video, etc)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0