Jump to content
Sign in to follow this  
Pavel

FileSaveDialog Problems

Recommended Posts

Pavel

How to create a filesave window that saves file with extension,

if user in filename box types only name, without extension?

I mean if i choose "Text Files(*.txt)" filetype,

why extension not adds to the file?

I think window support extension adding and other functions like default extension..

And be very nice if a window appears in center, and window don't show recent file list

Can anyone help me?

Edited by Pavel

Share this post


Link to post
Share on other sites
marfdaman

$file = FileSaveDialog("Title", @DesktopDir, "Text Files (*.txt)")
If StringRight($file, 4) <> ".txt" Then $file &= ".txt"
;~ MsgBox(0, $file, $file)

Alzo


Don't take my pic to serious...~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~You Looked, but you did not see!~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites
marfdaman

I don't know about that, srry :D


Don't take my pic to serious...~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~You Looked, but you did not see!~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites
Jos

Thanks, but if I have a two filter types, for example .txt and .mp3 ?

How would you ever know what to choose when the extension isn't typed or selected and you have a filter with multiple extension options?

|


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.