Sign in to follow this  
Followers 0
osakamza

Script ACDsee 8

6 posts in this topic

My script not work in the final of instalation del Acdsee 8

This is my scrip:

Run("ACDSEE.EXE")

WinWaitActive("ACDSee 8","ACDSee 8 - InstallShield Wizard")

Send("{ENTER}")

WinWaitActive("ACDSee 8","I agree to the terms of this agreement", 3 )

Send("{E}")

Send("{ENTER}")

WinWaitActive("ACDSee 8","Asistente InstallShield para ACDSee 8", 3 )

Send("{TAB}")

Send("{TAB}")

Send("{TAB}")

Send("xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx")

Sleep(3000)

Send("{ENTER}")

WinWaitActive("ACDSee 8","Tipo de instalación", 2)

Send("{ENTER}")

WinWaitActive("ACDSee 8","Configuración de la integración Shell", 3 )

Send("{ENTER}")

WinWaitActive("ACDSee 8","Preparado para instalar el programa")

Send("{ENTER}")

WinWaitActive("ACDSee 8","Finalizado ACDSee 8 - InstallShield Wizard")

MouseMove(201, 197)-------------- no work this action quita el tilde

MouseClick("left", 201, 197, 2)---- no workk this action quita el tilde

Send("{ENTER}")

Share this post


Link to post
Share on other sites



Welcome to the forum.

Support questions belong in the Support section of the forum.


SciTE for AutoItDirections for Submitting Standard UDFs

 

Don't argue with an idiot; people watching may not be able to tell the difference.

 

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

You are using Send and MouseClick in your script, which is very "risky" to use,

since the user can easily mess up the way your script is supposed to work by

just pressing the keyboard or by moving the mouse.

I suggest using ControlSetText and ControlClick instead, which works directly

with the controls, which also removes the need to have the window active !

By doing that it's a good chance that your script will work again..

Edit : ooh, and as gafrost said, this is not the right forum to ask questions.

Like it says on the top of this page, "This is not a general support forum!".

This is the place to share finished scripts.

Edited by Helge

Share this post


Link to post
Share on other sites

Are you talking to me ? If so, why do you ask ? If you mean that I'm crazy-mad

then you're probably correct, but if you mean angry-mad then you're incorrect.

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Sorry Helge, i was referring to the first post. You might switch to Outline mode for the forums, hehe.

Edited by Manadar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0