Jump to content
Sign in to follow this  
Jango

Winword and ControlSend

Recommended Posts

Jango

Hello,

I would like to send some characters to an open Winword with ControlSend but when i use AU3Info.exe and i place my mouse on the blank Winword page there is no Control ID :whistle:

How can i do to send characters to word and other applications with no Control ID ?

It will be cool if someone can write an example.

Thank you.

Share this post


Link to post
Share on other sites
Jango

This was done for word yesterday, you might see if you can mod it:

http://www.autoitscript.com/forum/index.ph...st&p=219558

Thanks but it's not exactly what i want, i have to send characters to other apps too like lotus notes.

We here have a keyboard problem, we can't send the euro symbol so i wrote this little script:

#include <GUIConstants.au3>

Global $Paused
HotKeySet("{F2}", "SendEuro")
HotKeySet("{ESC}", "Terminate")

; == GUI generated with Koda ==);
$Form2 = GUICreate("Keys", 307, 73, 302, 218)
GUISetState(@SW_SHOW)
While 1
    $msg = GuiGetMsg()
    Select
    Case $msg = $GUI_EVENT_CLOSE
        ExitLoop
    Case Else
        ;;;;;;;
    EndSelect
WEnd

Exit

Func SendEuro()
    Send("€", 1)
EndFunc
;_WwG1

Func Terminate()
    Exit 0
EndFunc

When i press F2 it send the euro symbols but on some terminals it does work and i would like to send the char with ControlSend instead of Send.

But Winword have no Control ID

Perhaps should a do a mix of the link you gave me and my code but ...

Help

Edited by Jango

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.