Sign in to follow this  
Followers 0
t0ddie

Transfering source to new computer

23 posts in this topic

#1 ·  Posted (edited)

I have a program that i made a while back using autoit 3.1.1

I can run the script on the computer that i made the script on with no errors.

When i attempt to run the script on this computer i get errors.

i installed version 3.1.1 on this new computer. then i copied the include folder from my old computer to this one.. since it had been modified.

I still get this error on this computer

Line 93 (File "C:\Program Files\Autoit3\Include\GuiTab.au3"):

If IsHWnd($h_tabcontrol) Then

If ^ ERROR

Error: Unknown function name.

but the script runs fine on the other computer, same autoit version, same include folder.

other computer is a PC with windows xp pro.

this computer is a laptop with windows xp home.

i dont know why that would have anything to do with causing this error, but its the only difference that i can see between the 2 computers.

Here is a copy of the Include folder, ill add it now just in case its of some use..

www.diablouniverse.com/Include.zip

I just cant see what Im doing wrong here... I would like to be able to work on the script, on my new laptop.

Edited by t0ddie

Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites



HI,

maybe on the working pc you have GUITab.au3 in same folder as the script and on the new one not. :P

So long,

Mega


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

HI,

maybe on the working pc you have GUITab.au3 in same folder as the script and on the new one not. :P

So long,

Mega

maybe you might think that, since you havent downloaded the Include.zip folder and verified that GuiTab.au3 is in that .zip

heh...

afraid i already thought of that, this one is a stumper.

p.s. LOOK at the error, the path leads to the include folder.. not the scriptdir

Edited by t0ddie

Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

maybe you might think that, since you havent downloaded the Include.zip folder and verified that GuiTab.au3 is in that .zip

heh...

afraid i already thought of that, this one is a stumper.

p.s. LOOK at the error, the path leads to the include folder.. not the scriptdir

HI,

yes, I think you are right. I guess, the compiler looks first into the include folder and if he doesn't find the script he looks into the scriptDir. :P

So long,

Mega

I'll download the file and maybe it helps.


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

ok it just occurred to me, possibly..

i think i was using the beta version at the time... and maybe that function didnt get added into the final release of that version.

so, i had installed 3.1.1 from the site archive.

my actual version i think, is 3.1.1.0 on my other computer.. i dont know if thats the exact same version..

so its possibly NOT the same version of autoit.

would copying the entire autoit folder from my old computer onto this computer work? or would other things have to be changed like the registry and stuff. i dont think i have the install.exe for that on my computer anymore.

i dont even know if thats the problem, of if my proposal would be a solution that would work. just had an idea that maybe that could be a factor in why its not working.


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

IIRC, IsHWnd() is not in AutoIt 3.1.1.1. You may want to check the 3.1.1.1 helpfile installed on that PC to double check.

Share this post


Link to post
Share on other sites

What about installing the new release of Autoit and try to run your script then?

So long,

Mega


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

What about installing the new release of Autoit and try to run your script then?

So long,

Mega

i tried the new release first.

@mhz I checked the help file on the old computer where this script works... and it said 3.1.1 the compiler said 3.1.1.0

i made a new script on the old computer and clicked edit. it said 3.1.0 (WTF?)

STILL the include folder is the same...... i made a copy and replaced the include folder on this computer with the one from my old computer.

the ERROR comes from the include folder. it really should have nothing to do with the version.

i just installed the same version afterwards (when it did not work) to try and troubleshoot this.

EDIT: tried installing 3.1.0 still no luck

Edited by t0ddie

Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

Hi,

what about zipping the script to ececute with all the includes which are neccessary.

Then we'll see whether it works on other machines.

So long,

Mega


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

By new release, you downloaded 3.2 right?

Share this post


Link to post
Share on other sites

what about zipping the script to ececute with all the includes which are neccessary.

I used the old "hacked" exe2au3 to decompile the script, and that adds all of the includes to the beginning of the script. it STILL does not work on the other computer. i assume the computer its on is the only one it will work on until this is figured out...

By new release, you downloaded 3.2 right?

i went to the downloads page a few days before i posted this thread and downloaded the newest version, so most likely yes.

This is driving me nuts


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

Try closing all other processes on the computer.

I get HWind Errors when I am running some processes like Steam and some games.

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

i closed everything including internet explorer.

same error.

it says unknown function for the error...

so i look for the function in the include and i dont see it. its missing? yet it doesnt give that error on the other computer... and it has the same include folder.

maybe that function is hiding somewhere else? but no.. the path on the error says include folder....

dang it!

can someone find the function?

Edited by t0ddie

Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

does anyone recognise that function, and can point me to it?


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

Yes, I recognize the function - I wrote it. It's a built-in function. You should do what people tell you instead of continuing to be a dumbass all the time. You were told to make sure you have the latest version of AutoIt. You clearly did not follow this step and as a result you're wasting everone's time diagnosing a problem that boils down to "User is too stupid to listen to the answer he is given."

Share this post


Link to post
Share on other sites

Yes, I recognize the function - I wrote it. It's a built-in function.

Great

You should do what people tell you instead of continuing to be a dumbass all the time.

Excuse me?

You were told to make sure you have the latest version of AutoIt. You clearly did not follow this step and as a result you're wasting everone's time diagnosing a problem that boils down to "User is too stupid to listen to the answer he is given."

when are you going to grow up? you cant talk to people like that. whether you think they are idiots or not.

I cant forgive your "know it all" arrogance as you ASSumed you knew it all and didnt have to read the entire thread, which "clearly" shows that I already tried the solution that was provided. (see below)

What about installing the new release of Autoit and try to run your script then?

i tried the new release first.

you're wasting everone's time

Your posts that are aimed at heckling, and not providing answers is a waste of time.

so you made the function, are you just BOASTING? congratulations!!! because i could care less that you think you are better than me. If you know the solution say it, otherwise you are making yourself look like as ASS, I dont even need to point anything else out. nice childish name-calling there.. valik.

p.s. to anyone who is interested, the compiled version works on all the computers i try it on.

if that has any relevance. script wont run, but when compiled on the old computer, it runs on the new one.

p.s.s. Valik.. i havent posted any problems in here for a LONG time. Furthermore, I dont respect your opinion simply because your a disrespectful person to begin with, but you had mentioned that your rude to me because you think I post stupid questions. what a load of crap. You claimed you would stop disrespecting me if I stopped posting ALTOGETHER.... You cant even keep your own word.

Look at this thread, its PROOF that your wrong, and I am right.

you lashed out at me without bothering to read the entire thread.

and YES I know you will make a rebuttal, but i still fuckin own you bitch.

I can counter with name calling just as well if not better than you, Vaglik

go ahead and post something unproductive... waste more of your time. You are the idiot here.


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

#17 ·  Posted (edited)

Well, t0ddie, since you are the stupidest individual on the planet, let me tell you exactly what you have done since you are apparently too stupid to figure it out on your own.

On your old computer, you have a beta version of AutoIt. Versions starting from v3.1.1.66 have IsHWnd() built-in. You have compiled the script with a beta version on the old computer. Therefore, it will work on every computer. Now, on your new computer, you've installed 3.1.1.0, which does not have IsHWnd(). You've been told twice now to get the latest release of AutoIt. Both times you've went off on an idiot-rant instead of doing what you were told. Try downloading and installing 3.2.0.1 of AutoIt where you will find IsHWnd() and your problem will go away.

Edit: Added a couple sentences I forgot to write the first time.

And don't even go on another idiot-rant about having the latest version. You don't. Period. Don't assume you do. Look and see that you don't, get it, and shut up and leave the forum.

Edited by Valik

Share this post


Link to post
Share on other sites

Thank you for at least trying to be helpful, maybe my words made you realize that you were being too harsh.

you are both right and wrong.

You were right...

1. installing the latest version fixed the problem

You were wrong...

1. saying i wasnt listening when I did install the newest version available first on this laptop before trying the older version, and nobody stated that a new version JUST came out.

I already tried what was suggested before it was suggested, which is why i did not download the new version AGAIN.

the version must have JUST changed since I first got this laptop a couple months ago and thats why it now works.. i installed the newest avaiulable version of autoit as soon as i got this thing... and that was less than 2 months ago.

but regardless, the version was the newest available when i downloaded it, it just wasnt current at the time I started this thread. so I was listening.. i assume you were under the presumption that i tried to install ONLY the old version. i just hadent downloaded the newest version to date because i thought i already had it and was under the assumption that i tried that possibility already.

i had JUST downloaded it less than 2 months ago. and it was DEFINATELY newer than the version that i had on the other computer..

2. for continuing to talk down to me. nobody is stupid. ok vaglik?

other than that, thanks! it worked.


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

I did not change my demeanor because I thought I sounded harsh. You deserved everything you got (and more). I changed my demeanor because I knew exactly what the problem was and I thought it more fun to demonstrate that I know more about your setup than you do even though I have never encountered the machines in question. It seemed less fun to continue calling you stupid when I could simply prove the point and drive it home by knowing more about machines I've never seen than the owner.

You were specifically told by Icekirby1 to make sure that 3.2 was the version you had. At this point, before you did anything else, you should have looked to see what version of AutoIt you had installed. Instead, you assumed you had the latest version because you downloaded it a "few days before". It turns out that a "few days" to you is a couple months. Meanwhile, the new release is just barely over 2 weeks old. So really, you don't have any excuse.

So as far as I'm concerned, you got less than you deserved given that it took being told the same thing three times before you finally took the hint. I have cats that follow instructions in less repetitions than that.

Share this post


Link to post
Share on other sites

I did not change my demeanor because I thought I sounded harsh. You deserved everything you got (and more). I changed my demeanor because I knew exactly what the problem was and I thought it more fun to demonstrate that I know more about your setup than you do even though I have never encountered the machines in question.

I dont question youir intellect, I already was aware that you most likely knew the answer.

you could have answered it in the first post instead of dragging it on.

It seemed less fun to continue calling you stupid when I could simply prove the point and drive it home by knowing more about machines I've never seen than the owner.

I already said you were right, and saying somethng like this is being egotistical, which is an unnatractive quality in most peoples opinion.

You were specifically told by Icekirby1 to make sure that 3.2 was the version you had. At this point, before you did anything else, you should have looked to see what version of AutoIt you had installed. Instead, you assumed you had the latest version because you downloaded it a "few days before". It turns out that a "few days" to you is a couple months. Meanwhile, the new release is just barely over 2 weeks old. So really, you don't have any excuse.

Actually, I assumed I had the latest version UNTIL he mentioned 3.2

I then mentioned that I downloaded the version a few months ago, and BECAUSE I did not get any response as to the newest version being only 2 weeks old, I assumed that no version change had taken place since my download. to the best of my recollection, the "few days ago" quote was referring to the old version that I downloaded and tried, not 3.2.

So as far as I'm concerned, you got less than you deserved given that it took being told the same thing three times before you finally took the hint. I have cats that follow instructions in less repetitions than that.

I am ultimately responsible for not double-checking the version, however I am not stupid.

I DID make a rebuttal saying That I downloaded the newest version, semi-asking If that was the new release. that was downloaded "a few days" before 3.2 arrived and it slipped past me I guess. however, after I mentioned when I downloaded the latest version, not one person mentioned that a new version had recently come out. I would have definately double-checked the version. In my experience at these forums new versions dont come out extremely often. I posted within that buffer of a few days after i downloaded the old version, and during the time the new version had just came out.

simple mistakes happen, and I also learn from them.

I dont open up new threads asking the same questions.

I do appreciate your willingness to help, whatever the motivation is. I hesitantly read your posts as most of it I have to sort out as it is unenjoyable reading, and completely innappropriate.

you make one or two points, and badmouth me the rest of the time.

how is your relationship with your mother?

your comparisons of my intellligence to that of your cat is very dry humor, and is insulting.

whatever your opinion, keep it to yourself. nobody asked you to assess me. vaglik

If you treat people like this offline you must be very lonely.


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0