Sign in to follow this  
Followers 0
Earthquake

Need help with IE Automation

3 posts in this topic

Hi Snipez,

I programmed a little script, which fills some values to a form (some idiotic intranetpage, which wants the same values over and over again).

My problem is, that there is a combobox (lets call it "box2"), which chooseable values depend on the value of the combobox ("box1), which was clicked before.

The problem is, that I cant get the javaevent "Product_NewChange()" to run, so there are no chooseable options in "box2".

As I learned to read the help before I post :P , I checked, whether _IEFormElementSetValue would usually (as default) allow events to happen, but it doesnt work.

I know, without code, its difficult to answer the question, but I would have to delete all work related stuff (too much work!!!).

Thx a lot!


Yes, I am a noob! But at least I try to learn!Moddingtech.de - Home of the german Modding-Scene!

Share this post


Link to post
Share on other sites



Actually, it does work. The code is pretty straight forward:

$o_object.value = $s_newvalue
    If $f_fireEvent Then
        $o_object.fireEvent ("onchange")
    EndIf

Perhaps your event script is triggered by something other than onchange. You'll need to dig a little deeper.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

EDIT:

---------------------------------------------- SOLVED ------------------------------------------------------

I was an idiot again :P

Edited by Earthquake

Yes, I am a noob! But at least I try to learn!Moddingtech.de - Home of the german Modding-Scene!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0