Sign in to follow this  
Followers 0
BitRot

SciTE editor : how to make tab & indentation settings permanent

5 posts in this topic

Maybe a thousand-times answered question, but here goes : I would like to have, in the SciTe editor, both the Tab and Indentation-settings set to 2 (options -> Change indentation settings) .

I can do that allright, but only for the current session. Whenever I close the editor those settings seem to get lost, and I have to re-enter them again when opening it the next time.

Is the any way (I currently do not see) to store those settings as preferences (ini-file, registry, anywhere) ?

Allso, is there a way to tell the editor to use the ".au3" extentions as a default when saving a file (currently the file does not automatically get an extention when saving the first time, or when using "Save as")

Share this post


Link to post
Share on other sites



Welcome,

1. For a permanent setting, go to Tools -> Scite Config or use Ctrl+1. Look at bottom of window tab to adjust the setting and then press Update button to finish. The settings are saved to your User Options.

2. No setting available for the extension when saving.

:)

Share this post


Link to post
Share on other sites

Welcome,

Thanks :)

1. For a permanent setting, go to Tools -> Scite Config or use Ctrl+1.

Neither "Tools -> Scite Config" seems to be available, nor does pressing "ctrl+1" have any effect (My SciTe editor version is 1.70)

2. No setting available for the extension when saving.

Hmmm ... Maybe I should try to write an AutoIt script that will add such a setting to that particular control .... :P

Thanks for the response.

Share this post


Link to post
Share on other sites

You must be using the light version that comes with the AutoIt install. You can set it by adding the below to your Options -> Open User Options File. Change to your needs.

use.tabs=1
indent.size=4
indent.size.*.au3=4
tabsize=4

Or if you want the full version then you can go to here and download it.

:)

Share this post


Link to post
Share on other sites

You must be using the light version that comes with the AutoIt install.

Correct. :P I must say I cannot remember having seen any message/warning to that effect (it being the light version). Ofcourse, that might have something to do with the fact that I used .ZIP version instead of the installer.

You can set it by adding the below to your Options -> Open User Options File.

I allready saw and tried that option, but was met with an empty file and no hints/instructions what to do there :)

Thanks, copying those settings and changing the last two "4"-rs to "2"-s seem to have done the trick. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0