Jump to content
Sign in to follow this  
eHrgo

[InetGet] - Always @error. was working!

Recommended Posts

Hum sorry, working but still have a problem, its asking me everytime the page refresh If i want to display the secured item ...

I can't use the IE fucs because of that:

Posted Image

How can I solve it? another function? Hide this message? Thanks

have you tried using an adlib function to watch for that window?

Share this post


Link to post
Share on other sites

Hum sorry, working but still have a problem, its asking me everytime the page refresh If i want to display the secured item ...

I can't use the IE fucs because of that:

Posted Image

How can I solve it? another function? Hide this message? Thanks

Set the browser permissions correctly? I have no idea about vista personally... I'm just staying away from it until I don't have a choice. All my scripts have
If @OSVersion = 'WIN_6.0' Or @OSVersion = 'WIN_6.1' Then
    MsgBox(16, 'Error', 'Are you kidding?')
    Exit
EndIf
At the top :whistle: !

Maybe this ugly work around could work for you too:

http://www.autoitscript.com/forum/index.ph...st&p=316046


Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

lol great, you should explain: Are you mad?

Thanks, but IeCreate Takes too much time and too much Ram .... I suceed to disable the message but I want to make it public.

Can't I get the Source from another way? [Fast one]


Sorry for my Bad English.

Share this post


Link to post
Share on other sites

lol great, you should explain: Are you mad?

Thanks, but IeCreate Takes too much time and too much Ram .... I suceed to disable the message but I want to make it public.

Can't I get the Source from another way? [Fast one]

Use a 3rd party program... you've just shut out the 2 ways we do it ... _InetGetSource() and _IE... time to go hunting.

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

.....

I tried with two other Secured webpage with an Inetget, working great [Ebay, Paypal] Whats wrong with that.

Im giving up.


Sorry for my Bad English.

Share this post


Link to post
Share on other sites

.....

I tried with two other Secured webpage with an Inetget, working great [Ebay, Paypal] Whats wrong with that.

Im giving up.

I'm telling you... the solution to all your problems is :
If @OSVersion = 'WIN_6.0' Or @OSVersion = 'WIN_6.1' Then
    MsgBox(16, 'Error', 'Are you kidding?')
    Exit
EndIf
:P:whistle:

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Thanks ... Wepage added to trusted site, but my InetGet is still failing.

Desperate.


Sorry for my Bad English.

Share this post


Link to post
Share on other sites

does

curl -k https://user:pw@ssl.rapidshare.com/cgi-bin/collectorszone.cgi
work for you?

(dont forget to change user and pw to your username/password...)

if yes you may wrap it with run and stdoutread...

edit:

if authentication doesn't work try:

curl -k -d username=<user> -d password=<pw> https://ssl.rapidshare.com/cgi-bin/collectorszone.cgi
Edited by piccaso

CoProc Multi Process Helper libraryTrashBin.nfshost.com store your AutoIt related files here!AutoIt User Map

Share this post


Link to post
Share on other sites

Thanks,

Downloaded the Windows Xp [there is no vista] version of Curl. I put the .exe in Syst32 dir... Tried to launch a :

curl

And got that:

Posted Image

Didn't find anything in their FAQ... :whistle:

Edited by eHrgo

Sorry for my Bad English.

Share this post


Link to post
Share on other sites

Thanks ... Wepage added to trusted site, but my InetGet is still failing.

Desperate.

If you add it to the Trust Site then trying following.

From IE.

Tools >> Internet Options >> Security Tab >> High light Trusted Sites >> Custom Level button >> Under Miscellaneous Section, Change Display mixed content to Enable.

Share this post


Link to post
Share on other sites

Joon: Already tried it, thanks, still @error, whatever, I can't tell everyone to enable those options...

Piccaso: Thanks a lot, this one is working [i can't put it in System32 because both Dll are existing..] Working from another path [i will use @Scriptdir]

LOVE YOU.

Working, im gonna try to wrap it in autoit.


Sorry for my Bad English.

Share this post


Link to post
Share on other sites

Sooooooooo close.

I can't get Stdoutread work.. It doesn't return me my code... Searching.

$Curl=RunWait ( @ScriptDir&'\curl -k https://ssl.rapidshare.com/cgi-bin/collectorszone.cgi')
$txt=StdoutRead ( $Curl)
MsgBox(0,'', $txt)

Edit: I can see the HTML code on the prompt DOS window.

Not working with the Username and Password settings, but its not a problem.

Edited by eHrgo

Sorry for my Bad English.

Share this post


Link to post
Share on other sites

Sooooooooo close.

I can't get Stdoutread work.. It doesn't return me my code... Searching.

$Curl=RunWait ( @ScriptDir&'\curl -k https://ssl.rapidshare.com/cgi-bin/collectorszone.cgi')
$txt=StdoutRead ( $Curl)
MsgBox(0,'', $txt)

Edit: I can see the HTML code on the prompt DOS window.

Not working with the Username and Password settings, but its not a problem.

Ok, this I haven't seen mentioned in this thread before:

Note that in Vista just being an administrator is NOT enough for running activities that have security implications. Especially when you are using User Account Control (UAC). You need two things:

1 - #requireAdmin directive in start of script (this makes Vista popup a confirmation box - without this, all kinds of functions fail!!!)

2 - If you need to elevate an activity to LSA privileges (for instance for interacting with services that run under the LSA): in Vista only the ShellExecute API and ShellExecuteEx API kept their elevation rights.

So what happens if you include that directive, and try using ShellExecute() to generate some output?

Btw, I recently had other discussions about this kind of thing, see:

http://www.autoitscript.com/forum/index.php?showtopic=42213

http://www.autoitscript.com/forum/index.ph...mp;#entry315147


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites

Sooooooooooooooooooooooo . Stupid, im stupid, for sure I need it to work with username and password ... This one doesn't use IE cookies... I tried to go to:

https://username:password@ssl.rapidshare.com/cgi-bin/premiumzone.cgi

Not working, im gonna kill my self.

Edit Woups Bunny, thanks a lot for you explanation, but I found a way to generate the output.. [see bellow] :S sorry.

Edited by eHrgo

Sorry for my Bad English.

Share this post


Link to post
Share on other sites

Sooooooooooooooooooooooo . Stupid, im stupid, for sure I need it to work with username and password ... This one doesn't use IE cookies... I tried to go to:

https://username:password@ssl.rapidshare.com/cgi-bin/premiumzone.cgi

Not working, im gonna kill my self.

one down :whistle: Edited by cameronsdad

Share this post


Link to post
Share on other sites

try this one

Dim $sLogin = "user"
Dim $sPassw = "pw"
Dim $iPidCurl = Run(@ComSpec & " /c " & 'curl -k -d username=' & $sLogin & ' -d password=' & $sPassw _
                & ' https://ssl.rapidshare.com/cgi-bin/collectorszone.cgi', @ScriptDir, @SW_HIDE,2+4)
Dim $iPeek,$sOut
While 1
    $iPeek = StdoutRead($iPidCurl,0,True)
    If @error Then ExitLoop
    If $iPeek > 0 Then $sOut &= StdoutRead($iPidCurl,$iPeek)
WEnd
ConsoleWrite($sOut)


CoProc Multi Process Helper libraryTrashBin.nfshost.com store your AutoIt related files here!AutoIt User Map

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...