Jump to content
Sign in to follow this  
Doppio

msiexec help

Recommended Posts

Hi, Why doesn't the following script execute the setup, I have the msi in the crystal folder but it wont run

If Not FileExists(@UserProfileDir & "\Local Settings\Temp\Crystal4") Then DirCreate(@UserProfileDir & "\Local Settings\Temp\Crystal4")
FileInstall("c:\Crystal\crystal4.msi", @UserProfileDir & "\Local Settings\Temp\Crystal4\", 1)


run ("msiexec /i" & @UserProfileDir & "\Crystal\crystal4.msi")

Thank you for your help.

Share this post


Link to post
Share on other sites

Can yo elaborate, maybe an example?

Msi itself is not execultable, you need like Daemoon tool to mount it to be able to view what's inside.

Share this post


Link to post
Share on other sites

Msi itself is not execultable, you need like Daemoon tool to mount it to be able to view what's inside.

Ok not I understand. Thanks for the knowledge.

Share this post


Link to post
Share on other sites

replace

run ("msiexec /i" & @UserProfileDir & "\Crystal\crystal4.msi")oÝ÷ Ù¼ºÚ"µÍÚ[^XÝ]H
ÙÙ[Q  [È ][ÝÉÌLÐÜÝ[    ÌLØÜÝ[
ÚI][ÝÊoÝ÷ Úî±æ®¶­sg'Vâb33¶×6WV2ögV÷C²b33²fײW6W%&öfÆTF"fײb33²b3#´7'7FÂb3#¶7'7FÃBæ×6gV÷C²b33²
Thank you very much!, that did the trick.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...