Sign in to follow this  
Followers 0
Achilles

HotKeySet Problem

5 posts in this topic

#1 ·  Posted (edited)

HotKeySet("!", "_Logger")
HotKeySet("#", "_Logger")
HotKeySet("^", "_Logger")
HotKeySet("+", "_Logger")
HotKeySet("{", "_Logger")

While 1
    Sleep(100)
WEnd

Func _Logger()
    $keyPressed = @HotKeyPressed
    ConsoleWrite($keyPressed) ;See if this actually happens!
    HotKeySet($keyPressed)
    Send($keyPressed)
    HotKeySet($keyPressed, "_Logger")
EndFunc

Edited by Piano_Man

My Programs[list][*]Knight Media Player[*]Multiple Desktops[*]Daily Comics[*]Journal[/list]

Share this post


Link to post
Share on other sites



FIXED!!!

This has nothing to do with HotKeySet()

HotKeySet("!", "_Logger")
HotKeySet("#", "_Logger")
HotKeySet("^", "_Logger")
HotKeySet("+", "_Logger")
HotKeySet("{", "_Logger")

While 1
    Sleep(100)
WEnd

Func _Logger()
    $keyPressed = @HotKeyPressed
    ConsoleWrite($keyPressed) ;See if this actually happens!
    HotKeySet($keyPressed)
    Send($keyPressed, 1)
    HotKeySet($keyPressed, "_Logger")
EndFunc

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

instead of trying to set ! as a hotkey

try this:

+1

that would be a key combo of:

shift + 1

This is the way autoIT will detect your keystroke.

also ! is the input for ALT so i am not so sure how it will all affect..

Share this post


Link to post
Share on other sites

You both need to read a little more about the Send() Function

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

FIXED!!!

This has nothing to do with HotKeySet()

HotKeySet("!", "_Logger")
HotKeySet("#", "_Logger")
HotKeySet("^", "_Logger")
HotKeySet("+", "_Logger")
HotKeySet("{", "_Logger")

While 1
    Sleep(100)
WEnd

Func _Logger()
    $keyPressed = @HotKeyPressed
    ConsoleWrite($keyPressed) ;See if this actually happens!
    HotKeySet($keyPressed)
    Send($keyPressed, 1)
    HotKeySet($keyPressed, "_Logger")
EndFunc

8)

That was not the problem. The ConsoleWrite is not working, the keys are being sent fine.

@tAkTelapis: Your solution is what I was looking for...

I realized, after you said that "!" is the input for alt, every key I'm trying to push here is a shortcut for another one. For example Send("!{F5}") or Send("#r") or Send("^q")...

So I'll have to use the +1 and +3... thanks for that!


My Programs[list][*]Knight Media Player[*]Multiple Desktops[*]Daily Comics[*]Journal[/list]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0