Sign in to follow this  
Followers 0
qwertylol

iniwritesection array

6 posts in this topic

The data to write. The data can either be a string or an array. If the data is a string, then each key=value pair must be delimited by @LF. If the data is an array, the array must be 2-dimensional and the second dimension must be 2 elements.

I don't quite understand this. I know what @LF but for the data being an array, how exactly should I arrange my data?

Share this post


Link to post
Share on other sites



I don't quite understand this. I know what @LF but for the data being an array, how exactly should I arrange my data?

Have you looked at the examples that show how its done ?

:)


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

yes, but this doesn't work.

$data[2][2] = [["x_offset", $x_offset] , ["y_offset", $y_offset ]]

Share this post


Link to post
Share on other sites

yes, but this doesn't work.

$data[2][2] = [["x_offset", $x_offset] , ["y_offset", $y_offset ]]

Would help when you specify what isn't working......

This example works for me:

$x_offset = 1
$y_offset = 2
Dim $data[2][2] = [["x_offset", $x_offset],["y_offset", $y_offset]]
IniWriteSection("test.ini", "SectionTest", $Data, 0)

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Dim $data
Dim $x_offset = 1
Dim $y_offset = 1

$data[2][2] = [["x_offset", $x_offset],["y_offset", $y_offset]]
IniWriteSection("test.ini", "SectionTest", $Data, 0)

This doesn't work for me, btw I am using

autoit-v3.2.4.0-rc1-setup.exe 07-May-2007 03:17 3.9M

from http://www.autoitscript.com/autoit3/files/beta/autoit/

You are missing the Dim Statement!

Dim $data[2][2] = [["x_offset", $x_offset],["y_offset", $y_offset]]

:)


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0