Jump to content
Sign in to follow this  
Gif

_ie image problem

Recommended Posts

Gif

I have a problem with an image that i want to be clicked or even better if i can get the link of that image(a href) not the source of the image..

this is the source of the picture:

<table style="BORDER: none; WIDTH: 700px"><tbody><tr><td style="BORDER: none"><p align="left"><a href="http://youtube.com/get_video?video_id=xoIsHwTq8Og&t=OEgsToPDskL4lobK7q1A_DbVaCIq8c6Z&soff=1&sk=y6uaBQDsCwpxDB64juPIhQR"><img src="./vd/botdl.gif" align="middle" border="0" /></a></p></td>

and this is what i use:

$str = StringSplit($site, "=")
$URL = _IECreate($f_LINK & $str[2], 0, 1, 1, -1)
 $oIMG = _IEImgClick($URL, "./vd/botdl.gif", "src")

but the result is:

--> IE.au3 Warning from function _IEImgClick, $_IEStatus_NoMatch

IE finds no match for the picture...

any help would be appreciated

Share this post


Link to post
Share on other sites
DaleHohm

It could be that the path is being expanded... try:

$oLinks = _IELinkGetCollection($oIE)
For $oLink in $oLinks
    ConsoleWrite($oLink.src & @CR)
Next

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
Gif

It could be that the path is being expanded... try:

$oLinks = _IELinkGetCollection($oIE)
For $oLink in $oLinks
    ConsoleWrite($oLink.src & @CR)
Next

Dale

OK now it finds the links, using $oLink.href

but there are 4 links and i want the only the 3rd one to be shown in a msgbox

how to do that?

Share this post


Link to post
Share on other sites
Gif

OK now it finds the links, using $oLink.href

but there are 4 links and i want the only the 3rd one to be shown in a msgbox

how to do that?

ok solved the problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.