Jump to content
Sign in to follow this  
LuckyMurari

Vista Sidebar Style To DO List

Recommended Posts

LuckyMurari

I saw this topic of to do list somewhr in the forum..but could n't find it agin...I made some changes to each to add autohide to it to make it luk like Vista Side Bar...I think this can be further changed to make Vista Style SideBar....Please suggest to improve the code and any ideas for it

todo.au3

Edit:changed code to suit all the desktop heightstodo1.1.au3......

Edit2:Added custom transition speed and task speed and also optimized the CPU usage...thanx To SMASHLY

Edit3:Added One more Transition type:Now holds Fade and Slide Transition Types

todo1.2.au3

Edited by LuckyMurari

Share this post


Link to post
Share on other sites
LuckyMurari

21 dwnloads n no replies?? :rolleyes: Does that mean no bugs?no need for improvements?

Share this post


Link to post
Share on other sites
Skrip

It doesn't work for me. The new task doesn't add to the GUI.


[left][sub]We're trapped in the belly of this horrible machine.[/sub][sup]And the machine is bleeding to death...[/sup][sup][/sup][/left]

Share this post


Link to post
Share on other sites
smashly

Hi,

Nice, but I think the step in and out amount needs to be reduced.

The reason I say this is I get tearing of the gui as it appears or disappears.

Once the gui has fully appeared it's fine , it's mainly at the transition stage as it's appearing or disappearing tearing occurs.

Setting the step to a smaller amount corrects this and makes it look smoother while in transition.

Maybe offer the transition speed settings config and or type of transition. eg: Slide, Fade, Explode, Implode... etc

In those config settings also offer the user to set the transparency level as well as the background colour and text colour.

Maybe add a check to see the height of a users toolbar and the destop resolution, so you can make the gui height meet the toolbar when loaded.

This way the sidebar fills from the top of the screen to the toolbar no matter the screen res and toolbar height a user has their desktop set as. This part can be tricky as not all users have their toolbar on bottom of the screen.

Can post an example of finding the toolbar position and size if you like.

Overall I thoroughly like the colour/ transparency of the sidebar, simple and effective.

Thank you for sharing.

Cheers

Edit: Yep the Tasks don't add for me either.

Edit Again: Maybe also add an option for delay to dissapear.

eg: mouse away from zone for 0 (current setting) or 1 or 2 or 3 or 4 secs ..etc before hiding the gui.

Edited by smashly

Share this post


Link to post
Share on other sites
LuckyMurari

Hi,

Nice, but I think the step in and out amount needs to be reduced.

The reason I say this is I get tearing of the gui as it appears or disappears.

Once the gui has fully appeared it's fine , it's mainly at the transition stage as it's appearing or disappearing tearing occurs.

Setting the step to a smaller amount corrects this and makes it look smoother while in transition.

Maybe offer the transition speed settings config and or type of transition. eg: Slide, Fade, Explode, Implode... etc

In those config settings also offer the user to set the transparency level as well as the background colour and text colour.

Maybe add a check to see the height of a users toolbar and the destop resolution, so you can make the gui height meet the toolbar when loaded.

This way the sidebar fills from the top of the screen to the toolbar no matter the screen res and toolbar height a user has their desktop set as. This part can be tricky as not all users have their toolbar on bottom of the screen.

Can post an example of finding the toolbar position and size if you like.

Overall I thoroughly like the colour/ transparency of the sidebar, simple and effective.

Thank you for sharing.

Cheers

Edit: Yep the Tasks don't add for me either.

Edit Again: Maybe also add an option for delay to dissapear.

eg: mouse away from zone for 0 (current setting) or 1 or 2 or 3 or 4 secs ..etc before hiding the gui.

Thanq smashly for ur ideas...they r very nice i'll try to implement them...coming to the new tasks not appearing i think i have added the wrong file...now i uploaded the right one plz check out

Share this post


Link to post
Share on other sites
smashly

Hi,

Thank you for the update and your welcome.

But the script closes when I try to add a To-Do to the list..

C:\#AutoIt Projects Misc\todo1.1.au3 (72) : ==> Array variable subscript badly formatted.: 
$task[$i]=GUICtrlCreateLabel("x " & $a,0,@DesktopHeight,200,28) 
$task[^ ERROR
+>21:36:47 AutoIT3.exe ended.rc:0
+>21:36:48 AutoIt3Wrapper Finished
>Exit code: 0   Time: 16.430

With the first script I could add the task providing I didn't show the gui before adding the task.

If I added the task after showing the gui once then the task would add , but it would travel up the screen till it went past the To-Do at the top of the gui making it not visible.

keep them updates coming ..lol :rolleyes:

Cheers

Edit: For the delete a To-Do to work I think you'll need to change

Opt("GUIOnEventMode")oÝ÷ ÚÚºÚ"µÍÜ
    ][ÝÑÕRSÛ][[ÙI][ÝËJH
Edited by smashly

Share this post


Link to post
Share on other sites
LuckyMurari

I don't know why that problem is aqppearing to you.....I declared the variables correctly..n it works for me....don't know why it's not working for u....i just added the option to change transition speed to the code...but power went off....so doing it again :rolleyes::rambo::x:mad::)

Share this post


Link to post
Share on other sites
smashly

Maybe it's because I'm still using AutoIt public 3.2.2.0 on this pc I'm on atm. My laptop is using a current version of AutoIt, just haven't got round to updating this pc yet. (due for format and being lazy..lol) Will test it out a bit later on the lappy.

Another problem I'm finding is while the sidebar is showing it's using 100% cpu usage.

I think you'll need to maybe change the way the loop is holding the sidebar open, otherwise it's to labor intensive on cpu load for the task it's doing.

Time and commitment will see it right. :rolleyes:

Cheers

Share this post


Link to post
Share on other sites
smashly

To lower the cpu usage while the gui is showing you could use this ...

$State = 0

While 1
    $arr=MouseGetPos()
    If $arr[0] > @DesktopWidth-10 And $State = 0 Then
        For $i=20 To 200 Step 2
            WinMove("To Do","",@DesktopWidth-$i,0)
        Next
        $State = 1
     EndIf
    If $arr[0] < @DesktopWidth-200 And $State = 1 Then
        For $i=200 To 0 Step -2
            WinMove("To Do","",@DesktopWidth-$i,0)
        Next
        $State = 0 
    EndIf    
     Sleep(100)
WEnd

Will post more food for thought as I look at your script if you like.

Cheers

Share this post


Link to post
Share on other sites
LuckyMurari

To lower the cpu usage while the gui is showing you could use this ...

$State = 0

While 1
    $arr=MouseGetPos()
    If $arr[0] > @DesktopWidth-10 And $State = 0 Then
        For $i=20 To 200 Step 2
            WinMove("To Do","",@DesktopWidth-$i,0)
        Next
        $State = 1
     EndIf
    If $arr[0] < @DesktopWidth-200 And $State = 1 Then
        For $i=200 To 0 Step -2
            WinMove("To Do","",@DesktopWidth-$i,0)
        Next
        $State = 0 
    EndIf    
     Sleep(100)
WEnd

Will post more food for thought as I look at your script if you like.

Cheers

i would always welcome any suggestions...n this one is really nice...the state thing helps at new task also..thanx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×