Sign in to follow this  
Followers 0
notta

Command line causes flashing box

3 posts in this topic

I know this may be a limitation of Autoit, but is there some method of keeping your main GUI from flashing when you run a compec command? I created a tool to nslookup multiple machine on my network, but the main GUI is flashing like crazy.

RunWait(@ComSpec & " /C nslookup " & $aRecords[$k] & $domext & " |find ""Address:""" & " > " & $tmpdir & $tmpfile,"",2)

I imagine the command window is flashing in front of the GUI. Is there some way to send the comspec to the background? Thanks.

Share this post


Link to post
Share on other sites



Check the helpfile for WinSetState and @SW_HIDE. I have used that to hide command windows before.


Support bacteria; it's the only culture most people have.LxP's Learning to Script with AutoIt 3 - Excellent starting placeVolly's Links Page - Links to cool and useful scriptsAutoIt Wrappers - Valuater's AutoIt Wrappers post. Lots of good stuff.Support AutoIt - Make a donation here; I did.[size="2"]#include <Guinness.pint>[/size]

Share this post


Link to post
Share on other sites

Actually the command window is hidden with the command above, but the main GUI windows loses focus on every cycle through the loop to nslookup each machine. While this is running you can't even open the start menu without it being interrupted. Not really problem when you are using it to lookup 10 machines, but when doing a 1000 it gets annoying :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0