Sign in to follow this  
Followers 0
Gestalt

Trying to Compile Multiple Scripts

6 posts in this topic

I am not sure if this is a problem with AutoIt or it is with my Windows Explorer since my home computer has no problem, just my work computer.

Even since upgrading to the latest build (3.2.4.9), I have been unable to select multiple scripts and then compile them by right-clicking and selecting Compile from the right-click menu. Now if I do that, nothing happens. At all.

I can still compile one script using that method, I just cannot compile more than one at a time. Is there a way to set it so I can compile more than one script at a time?

Thanks!

Share this post


Link to post
Share on other sites



I am not sure if this is a problem with AutoIt or it is with my Windows Explorer since my home computer has no problem, just my work computer.

Even since upgrading to the latest build (3.2.4.9), I have been unable to select multiple scripts and then compile them by right-clicking and selecting Compile from the right-click menu. Now if I do that, nothing happens. At all.

I can still compile one script using that method, I just cannot compile more than one at a time. Is there a way to set it so I can compile more than one script at a time?

Thanks!

CODE
@Echo Off

Echo. > CompileAll.LOG

For %%F in (*.au3) Do "X:\Program Files\AutoIt3\Aut2Exe.exe" /in %%~nF.au3 /out %%~nF.exe /icon %%~nF.ICO >> CompileAll.LOG

Save this as compileall.cmd in the same folder as your scripts and run it.

Ralph

Share this post


Link to post
Share on other sites

I can still compile one script using that method, I just cannot compile more than one at a time. Is there a way to set it so I can compile more than one script at a time?

Are you sure? as I can do multiple script with 3.2.4.9 and with 3.2.5.0.

Using this script

$string = RegRead('HKLM\SOFTWARE\Classes\AutoIt3Script\Shell\Compile\Command', '')
If Not @error Then
    MsgBox(0x40000, '', $string)
Else
    MsgBox(0x40000, '', 'Unable to read from the registry')
EndIf

Produces for me

"C:\Program Files\AutoIt3\Beta\Aut2Exe\Aut2Exe.exe" /in "%I"

Even works if I remove the Beta dir from the path.

:whistle:

Share this post


Link to post
Share on other sites

"C:\Program Files\AutoIt3\Beta\Aut2Exe\Aut2Exe.exe" /in "%I"
I have the same path (minus the beta) in the registry. It is strange because I can compile one script without problem but anything more and it doesn't do anything at all. Not even an hour glass to show it is thinking about doing something.

Share this post


Link to post
Share on other sites

Perhaps the scripts are not highlighted when you right click? Try creating 2 new blank scripts. Highlight both with a right click drag action, then release the button and select compile from the context menu that pops up. Does that work? :whistle:

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Perhaps the scripts are not highlighted when you right click? Try creating 2 new blank scripts. Highlight both with a right click drag action, then release the button and select compile from the context menu that pops up. Does that work? :whistle:

The scripts are definitely selected before right-clicking. Just so you know, I am a Systems Administrator and Software Developer so something like making sure files are selected are something I don't usually screw up. :lmao:

As I mentioned before, my home computer (which has the same version of AutoIt) works fine so I am not sure whether it has something to do with AutoIt or if something has gone horribly wrong with the computer. I'm sure there is a registry setting somewhere I can change; I just don't know where that might be. I can use RDSchaefer's idea temporarily--but create the compiler script in AutoIt, of course--but I don't want to have to do that for all of my scripts. I have 20 logon scripts that I need to compile whenever I make changes and compiling one at a time is not very much fun.

Thanks for your replies.

Edit: This is a problem with the computer, not AutoIt. I tested it by selecting multiple text documents and trying to open then in Notepad++ and they wouldn't open. However, I can open a text file if I only select one text file. Since this is not AutoIt related, feel free to ignore my post below. However, if you do have an answer to this Windows problem, I would love to hear the solution.

Thanks!

Edited by Gestalt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0