Sign in to follow this  
Followers 0
sheno

_IELinkClickByText ! need to help

7 posts in this topic

I have a problem with _IELinkClickByText . Can everybody help me to use autoit to click on this link

nhấn vào

Many thanks. I come from VietNam. :)

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

If you're having trouble matching text because of the language, try using an indexed instance instead, by way of _IELinkClickByIndex.

Edited by mikehunt114

IE Dev ToolbarMSDN: InternetExplorer ObjectMSDN: HTML/DHTML Reference Guide[quote]It is surprising what a man can do when he has to, and how little most men will do when they don't have to. - Walter Linn[/quote]--------------------[font="Franklin Gothic Medium"]Post a reproducer with less than 100 lines of code.[/font]

Share this post


Link to post
Share on other sites

Anotherway ? The webpage have that link is not statics(and have many many link...). Let help me, plz.

Thanks.

Share this post


Link to post
Share on other sites

I have a problem with _IELinkClickByText . Can everybody help me to use autoit to click on this link

nhấn vào

Many thanks. I come from VietNam. :)

_IELinkClickByText($oIE, "nhấn vào") should work, but I must admit to not being able to test with unicode.

The string specified must exactly match the test of the link -- sometimes leading or trailing spaces can trick you.

You may want to use this to get more info:

$oLinks = _IELinkGetCollection($oIE)
$i = 0
For $oLink in $oLinks
    ConsoleWrite("Link index: " & $i & "  Link Text: [" & _IEPropertyGet($oLink, "innerText") & "]" &@CR)
    $i += 1
Next

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Yeah !!! It run ... Thanks :)

Share this post


Link to post
Share on other sites

What worked? Where you able to use the unicode text?

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Yeah !!! That's it. hehe :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0