Sign in to follow this  
Followers 0
-Ultima-

_GUICtrlListViewInsertItem() doesn't accept Unicode

3 posts in this topic

#1 ·  Posted (edited)

UnicodeListView.au3

Try running the attached script, then look at the source code; you'll see what I'm talking about :)

I'm not sure if it's a known limitation, but I tried searching the forums (to no avail). Is there any way around this, or is there any plan to fix it? I would use GUICtrlCreateListViewItem(), but it won't scale up nicely if there's a possibility that my GUI will contain lots of listview items (enough to hit the 4096 control limit) :\

I tried messing with GUIListView.au3 by replacing $LVM_INSERTITEMA with $LVM_INSERTITEMW (defined as $LVM_FIRST + 77), but it didn't help (unsurprisingly).

Edited by -Ultima-

[ WinINet.au3 | Array.au3 (Optimized) | _UnixTimeParse() ]

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0