Sign in to follow this  
Followers 0
LOULOU

IE3 Question about META NAME TAG acceding trough the dOM

2 posts in this topic

I try to access to a meta name object with thz following instruct

_IETagNameGetCollection ( $oie, "META" )

An error return saying that's there is no match and i verify that the tag was present in my file.

Thanks in advance

Share this post


Link to post
Share on other sites



Perhaps you are missing a FRAME or iFRAME?

It works fine... the webpage for this post has one META tag and this finds and displays it:

#include <IE.au3>

$oIE = _IECreate("http://www.autoitscript.com/forum/index.php?showtopic=54211&hl=")
$oMetas = _IETagnameGetCollection($oIE, "META")
ConsoleWrite(@extended & @CR)
For $oMeta in $oMetas
    ConsoleWrite(_IEPropertyGet($oMeta, "outerHTML"))
Next

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0