Sign in to follow this  
Followers 0
Insolence

Agh, traytip problem.

31 posts in this topic

HotKeySet("{PAUSE}", "Display")

; ----------------------------------------------------------------------------
; Infinite Loop
; ----------------------------------------------------------------------------

While 1
  Sleep(1000) 
Wend

; ----------------------------------------------------------------------------
; Functions
; ----------------------------------------------------------------------------

Func Display()
  TrayTip ( "Usage Timer asdfasdf", Time() & " --- asfdasfdasdfasdfafsdasfasf", 5, 1 ) 
EndFunc

Func Time()
    $hour=@hour
  If $hour > 12 Then
    $hour = $hour - 12
  EndIf
    
    Return $hour & ":" & @MIN
EndFunc

Very weird... I tried searching for it, but the search feature on here blows -.-


"I thoroughly disapprove of duels. If a man should challenge me, I would take him kindly and forgivingly by the hand and lead him to a quiet place and kill him." - Mark TwainPatient: "It hurts when I do $var_"Doctor: "Don't do $var_" - Lar.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Just to get the obvious out of the way... You are running this on Windows 2000 or later on a system that does have Balloon Tips enabled, correct? The example works fine for me.

Edit: Typos (Fixed).

Edited by Valik

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Windows XP SP2 :)

--NOT SURE about the ballon tip thing, I can hear it, but I don't see it... where do I enable/disable it?

Edited by Insolence

"I thoroughly disapprove of duels. If a man should challenge me, I would take him kindly and forgivingly by the hand and lead him to a quiet place and kill him." - Mark TwainPatient: "It hurts when I do $var_"Doctor: "Don't do $var_" - Lar.

Share this post


Link to post
Share on other sites

Does the helpfile example for TrayTip work correctly for you?

I don't know where the option is. It may just be a registry setting exposed through 3rd party tweaking applications (Obviously, manually editing the proper key would have the same effect).

Share this post


Link to post
Share on other sites

None work.

But, I DO hear the noise... very odd.


"I thoroughly disapprove of duels. If a man should challenge me, I would take him kindly and forgivingly by the hand and lead him to a quiet place and kill him." - Mark TwainPatient: "It hurts when I do $var_"Doctor: "Don't do $var_" - Lar.

Share this post


Link to post
Share on other sites

Make sure you have all open windows minimized... then see if the TrayTip appears.

Strange things happened already for me, like the TrayTip disappearing behind open windows.

Kendall

Share this post


Link to post
Share on other sites

Does this example play a sound:

TrayTip("Test", "Test", 5, 16)
Sleep(5000)   ; 5 Seconds

Share this post


Link to post
Share on other sites

I tried that, and no :)

Thanks for your help, Valik, I appriciate it... is this a common problem?


"I thoroughly disapprove of duels. If a man should challenge me, I would take him kindly and forgivingly by the hand and lead him to a quiet place and kill him." - Mark TwainPatient: "It hurts when I do $var_"Doctor: "Don't do $var_" - Lar.

Share this post


Link to post
Share on other sites

No, I've never heard of anybody have a problem like this. And I'm out of ideas, so you're on your own, sorry.

Share this post


Link to post
Share on other sites

Could it possibly be that I'm running in Windows 98 style XP?


"I thoroughly disapprove of duels. If a man should challenge me, I would take him kindly and forgivingly by the hand and lead him to a quiet place and kill him." - Mark TwainPatient: "It hurts when I do $var_"Doctor: "Don't do $var_" - Lar.

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

A Tray tip will close if the AutoIt tray icon disappears. Consequently, the TrayTip may not appear if AutoItSetOption("TrayIconHide", 1) is set or if the user has disabled balloon tips via registry settings!

Check this registry setting Edited by CyberSlug

Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

It has nothing to do with your theme.

Share this post


Link to post
Share on other sites

It was 0, but after setting to 1, it still doesn't work.


"I thoroughly disapprove of duels. If a man should challenge me, I would take him kindly and forgivingly by the hand and lead him to a quiet place and kill him." - Mark TwainPatient: "It hurts when I do $var_"Doctor: "Don't do $var_" - Lar.

Share this post


Link to post
Share on other sites

Did you reboot or at least log-off and then back on? I think this setting requires that in order to take effect.

Share this post


Link to post
Share on other sites

I'll try that.


"I thoroughly disapprove of duels. If a man should challenge me, I would take him kindly and forgivingly by the hand and lead him to a quiet place and kill him." - Mark TwainPatient: "It hurts when I do $var_"Doctor: "Don't do $var_" - Lar.

Share this post


Link to post
Share on other sites

For some reason, the SP2 install disables the balloon popups. I was running XP SP1 on 4 boxes for a long time and recently updated Windows. This caused all my balloon popups to stop working. I don't think MS was very happy with people using their annoying little friend in their applications.

And yes this does require a reboot.

*** Matt @ MPCS

Share this post


Link to post
Share on other sites

For some reason, the SP2 install disables the balloon popups. I was running XP SP1 on 4 boxes for a long time and recently updated Windows. This caused all my balloon popups to stop working. I don't think MS was very happy with people using their annoying little friend in their applications.

And yes this does require a reboot.

*** Matt @ MPCS

<{POST_SNAPBACK}>

Interesting. Guess that should be added to the docs.

Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

Even more interesting is I have SP2 installed and it was never disabled on either of the two systems I installed it on.

If Microsoft didn't want people to use it, they just wouldn't of documented it. They've done that stuff before. There are tons of little API secrets that people have discovered that Microsoft never revealed.

Share this post


Link to post
Share on other sites

Did you upgrade to SP2 or use a streamline installation of Windows XP SP2? It is possible that if your PC came with SP2 or if you installed Windows with SP2 that whoever built the disk image changed the option on the disk, then not carrying over to your settings. Otherwise I can't explain it... all four of my machines had the problem while I was running my scripts right after updating.

I know MS hides crap in their operating system, but most of the undocumented api's can be found on the internet.

*** Matt @ MPCS

Share this post


Link to post
Share on other sites

I upgraded to SP2 by downloading the full redistributable version and using that to install on both (One is in a virtual machine).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0