Sign in to follow this  
Followers 0
ksmith247

FileCopy function fails

1 post in this topic

#1 ·  Posted (edited)

This script runs JkDefrag then chkdsk in perperation for installing some hard drive encryption software. My (current) issue seems to be with the function _CopyFiles(). I wind up with only one file (the chkdsk.log) in the share where the JkDefrag.log file should be copied too. If I run the function by itself in a test script it works but for some odd reason it doesn't work in the below context.

Any ideas?

Edit: For clarification

Edit2: Nevermind, the process was runing too fast. The remote server couldnt create the folder fast enough to receive the FileCopy. A short Sleep fixed it.

Edited by ksmith247

Support bacteria; it's the only culture most people have.LxP's Learning to Script with AutoIt 3 - Excellent starting placeVolly's Links Page - Links to cool and useful scriptsAutoIt Wrappers - Valuater's AutoIt Wrappers post. Lots of good stuff.Support AutoIt - Make a donation here; I did.[size="2"]#include <Guinness.pint>[/size]

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0