Jump to content
Sign in to follow this  
NewBe

Radio color problem

Recommended Posts

hmm this one is odd in koda I can get the radio text to go red but this doesn't work

#include <GUIConstants.au3>
GUICreate("My GUI" , 150 , 80) 
GUICtrlCreateInput("test", 0, 0, 60, 20)
GUICtrlSetColor(-1, 0xFF0000)
GUICtrlCreateLabel ("my Red label", 0 , 25)
GUICtrlSetColor(-1, 0xFF0000)
GUICtrlCreateRadio ("text", 0, 50, 100, 20)
GUICtrlSetColor(-1, 0xFF0000)

GUISetState ()      

While 1
    $msg = GUIGetMsg()
    Select
        Case $msg = $GUI_EVENT_CLOSE
            ExitLoop
    EndSelect
Wend

Share this post


Link to post
Share on other sites

HI NewBe,

this is correct, i had the same problem with GUICtrlCreateProgress but it can be fixed

#include <GUIConstants.au3>
GUICreate("My GUI" , 150 , 80) 
GUICtrlCreateInput("test", 0, 0, 60, 20)
GUICtrlSetColor(-1, 0xFF0000)
GUICtrlCreateLabel ("my Red label", 0 , 25)
GUICtrlSetColor(-1, 0xFF0000)
$Radio = GUICtrlCreateRadio ("text", 0, 50, 100, 20)
DllCall("UxTheme.dll", "int", "SetWindowTheme", "hwnd", GUICtrlGetHandle($Radio), "wstr", "", "wstr", "")
GUICtrlSetColor(-1, 0xFF0000)

GUISetState ()      

While 1
    $msg = GUIGetMsg()
    Select
        Case $msg = $GUI_EVENT_CLOSE
            ExitLoop
    EndSelect
Wend

Share this post


Link to post
Share on other sites

HI NewBe,

this is correct, i had the same problem with GUICtrlCreateProgress but it can be fixed

Thanks a lot...

I do not remember it being like this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...