Sign in to follow this  
Followers 0
Bert

Forum is messing up when editing post

18 posts in this topic

When a post has 2 blocks of code using the "{autoit]" code blocks, the second block will get turned to garbage when I try to edit to repost. I've tested this on 3 PCs in different locations, and get the same result.

I posted in the test thread to show what is happening.

http://www.autoitscript.com/forum/index.ph...400#entry457084

Share this post


Link to post
Share on other sites



When a post has 2 blocks of code using the "{autoit]" code blocks, the second block will get turned to garbage when I try to edit to repost. I've tested this on 3 PCs in different locations, and get the same result.

I posted in the test thread to show what is happening.

http://www.autoitscript.com/forum/index.ph...400#entry457084

As JamesB says. I gave up with AutoIt tags a long time ago and I always use code tags. I don't remember ever having a problem with code tags, I recommend them to all my friends.


Serial port communications UDF Includes functions for binary transmission and reception.printing UDF Useful for graphs, forms, labels, reports etc.Add User Call Tips to SciTE for functions in UDFs not included with AutoIt and for your own scripts.Functions with parameters in OnEvent mode and for Hot Keys One function replaces GuiSetOnEvent, GuiCtrlSetOnEvent and HotKeySet.UDF IsConnected2 for notification of status of connected state of many urls or IPs, without slowing the script.

Share this post


Link to post
Share on other sites

@Volly

Are you just noticing this now? No wonder people didn't understand my objections to using them. Occasionally it happens when you reply to someone that has used them as well.

I wish they would just be removed entirely until they work again. I think the problem has been there for the last 2 forum upgrades, maybe even longer.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Now, before anyone does, don't go blaming big_daddy for it, he has worked hard on them :)

You blew it JamesB. I knew it was someone on the forums that worked on it but I couldn't remember who. big_daddy might have prefered it stayed that way. :P

George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

I have the same problem very often but I discovered workaround.

I use Opera as main browser but for editing such posts with 2 autoit code tags blocks I use FireFox and Full edit method. In this case there is no corruption.

Note: IE and Opera makes corruption only FireFox works fine

Edited by Zedna

Share this post


Link to post
Share on other sites

I have the same problem very often but I discovered workaround.

I use Opera as main browser but for editing such posts with 2 autoit code tags blocks I use FireFox and Full edit method. In this case there is no corruption.

Note: IE and Opera makes corruption only FireFox works fine

I use Firefox and have often had the problem, but what is "full edit method"?


Serial port communications UDF Includes functions for binary transmission and reception.printing UDF Useful for graphs, forms, labels, reports etc.Add User Call Tips to SciTE for functions in UDFs not included with AutoIt and for your own scripts.Functions with parameters in OnEvent mode and for Hot Keys One function replaces GuiSetOnEvent, GuiCtrlSetOnEvent and HotKeySet.UDF IsConnected2 for notification of status of connected state of many urls or IPs, without slowing the script.

Share this post


Link to post
Share on other sites

I use Firefox and have often had the problem, but what is "full edit method"?

When you want edit your own post and click on Edit button at bottom of the post

then there are two choices: Full edit/Quick edit.

Share this post


Link to post
Share on other sites

What about this problem with the forums. It happens with code AND autoit tags.

That will happen anyplace where you start the string with "&#" and finish it with ";". I'm not sure if you can turn html off or not. I have a hunch that if you did then you would lose the tags but perhaps not.

George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

I think you are right, I think it's HTML with tags, or no HTML with no tags.

Share this post


Link to post
Share on other sites

Good thinking martin. Make html work against itself.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Missed the fact the problem has been reported before. Good to know what to do now. Thanks!

Look thru the posts below this one:

http://www.autoitscript.com/forum/index.ph...st&p=359949

One solution is to not edit - if you need to make a change, you can copy the info to the clipboard, delete you post and recreate it with your corrections.

Another way is to go into the edit mode, cut everything to the clipboard, post a blank "corrected post", re-edit, make your corrections and submit your corrected post. since this usually one affects my code in the post, I sometimes only cut the code between the tags and submit that as the corrected post - then re-edit and post the real corrected code.

All of the above is from memory - I could be forgetting a step - you know me :-)


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

Well I played with this again, but could not get it to mess up...

http://www.autoitscript.com/forum/index.ph...st&p=457260

I've not see the issue as of late because I've been handling it other ways, I rarely attempt to edit a post with [autoit tags].


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

I can provide a little different solution :)

Like this:

MsgBox(64, "Hi", "Hello World!")

If someone interesting in such method (highlight the syntax with forum tags), i can rewrite this app (wich is fully on russian language) so it will have an option to set languages (including English).

There is a source code, but all comments are in russian, just let me know, and i will try to find some time to rewrite the app (we use it on russian AutoIt topics, where no way to highlight the syntax).

P.S

@Zedna

I use Opera as main browser

You may want to look at AutoIt Menu for Opera Browser!, there is option (in last version) to integrate BBcode module, wich can be usefull to insert some tags, such as [autоit] :P - you simply select the code inside editing form, you press a hotkey (say, «a ctrl alt»), and all selected text wraped with autoit tags, if you press again, the tags removed.. you can do the same for any tags (code, b, i, u, img, url, color, etc.).

 

Spoiler

Using OS: Win 7 Professional, Using AutoIt Ver(s): 3.3.6.1 / 3.3.8.1

AutoIt_Rus_Community.png AutoIt Russian Community

My Work...

Spoiler

AutoIt_Icon_small.pngProjects: ATT - Application Translate Tool {new}| BlockIt - Block files & folders {new}| SIP - Selected Image Preview {new}| SISCABMAN - SciTE Abbreviations Manager {new}| AutoIt Path Switcher | AutoIt Menu for Opera! | YouTube Download Center! | Desktop Icons Restorator | Math Tasks | KeyBoard & Mouse Cleaner | CaptureIt - Capture Images Utility | CheckFileSize Program

AutoIt_Icon_small.pngUDFs: OnAutoItErrorRegister - Handle AutoIt critical errors {new}| AutoIt Syntax Highlight {new}| Opera Library! | Winamp Library | GetFolderToMenu | Custom_InputBox()! | _FileRun UDF | _CheckInput() UDF | _GUIInputSetOnlyNumbers() UDF | _FileGetValidName() UDF | _GUICtrlCreateRadioCBox UDF | _GuiCreateGrid() | _PathSplitByRegExp() | _GUICtrlListView_MoveItems - UDF | GUICtrlSetOnHover_UDF! | _ControlTab UDF! | _MouseSetOnEvent() UDF! | _ProcessListEx - UDF | GUICtrl_SetResizing - UDF! | Mod. for _IniString UDFs | _StringStripChars UDF | _ColorIsDarkShade UDF | _ColorConvertValue UDF | _GUICtrlTab_CoverBackground | CUI_App_UDF | _IncludeScripts UDF | _AutoIt3ExecuteCode | _DragList UDF | Mod. for _ListView_Progress | _ListView_SysLink | _GenerateRandomNumbers | _BlockInputEx | _IsPressedEx | OnAutoItExit Handler | _GUICtrlCreateTFLabel UDF | WinControlSetEvent UDF | Mod. for _DirGetSizeEx UDF
 
AutoIt_Icon_small.pngExamples: 
ScreenSaver Demo - Matrix included | Gui Drag Without pause the script | _WinAttach()! | Turn Off/On Monitor | ComboBox Handler Example | Mod. for "Thinking Box" | Cool "About" Box | TasksBar Imitation Demo

Like the Projects/UDFs/Examples? Please rate the topic (up-right corner of the post header: Rating AutoIt_Rating.gif)

* === My topics === *

==================================================
My_Userbar.gif
==================================================

 

 

 

AutoIt is simple, subtle, elegant. © AutoIt Team

Share this post


Link to post
Share on other sites

P.S

@Zedna

You may want to look at AutoIt Menu for Opera Browser!, there is option (in last version) to integrate BBcode module, wich can be usefull to insert some tags, such as [autоit] :) - you simply select the code inside editing form, you press a hotkey (say, «a ctrl alt»), and all selected text wraped with autoit tags, if you press again, the tags removed.. you can do the same for any tags (code, b, i, u, img, url, color, etc.).

Thanks for tip.

It looks really promising!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0