Sign in to follow this  
Followers 0
Xav

Click on a color

8 posts in this topic

How can my autoit click on a color DECIMAL not Hex ...?

And pixelsearch dont work with me i dont know why ne1 can help me ?

Thanks

Share this post


Link to post
Share on other sites



Its right there in your help file.

Function Reference > Variables and Conversions

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Its right there in your help file.

Function Reference > Variables and Conversions

Yeh i found but,

i tryed:

PixelSearch( 404, 314, 317, 415, 7039590 )

MosueClick("LEFT")

$Coord = PixelSearch( 404, 314, 317, 415, 7039590 )

MosueClick("LEFT")

Ne1 know why it wont go on the color ...? (the color is here !!!!)

But mouse dont go OVER and Don't click after :S :)

Edited by Xav

Share this post


Link to post
Share on other sites

Yeh i found but,

i tryed:

PixelSearch( 404, 314, 317, 415, 7039590 )

MosueClick("LEFT")

$Coord = PixelSearch( 404, 314, 317, 415, 7039590 )

MosueClick("LEFT")

Ne1 know why it wont go on the color ...? (the color is here !!!!)

But mouse dont go OVER and Don't click after :S :)

check your spelling...

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Yeh i found but,

i tryed:

PixelSearch( 404, 314, 317, 415, 7039590 )

MosueClick("LEFT")

$Coord = PixelSearch( 404, 314, 317, 415, 7039590 )

MosueClick("LEFT")

Ne1 know why it wont go on the color ...? (the color is here !!!!)

But mouse dont go OVER and Don't click after :S :)

$Coord = PixelSearch( 404, 314, 317, 415, 7039590 )
If IsArray($Coord) Then MouseClick("Left",$Coord[0], $Coord[1],1,0)

$Coord = PixelSearch( 404, 314, 317, 415, 7039590 )
If IsArray($Coord) Then MouseClick("Left",$Coord[0], $Coord[1],1,0)

This will work.

Edited by Bonchen

Share this post


Link to post
Share on other sites

$Coord = PixelSearch( 404, 314, 317, 415, 7039590 )
If IsArray($Coord) Then MouseClick("Left",$Coord[0], $Coord[1],1,0)

$Coord = PixelSearch( 404, 314, 317, 415, 7039590 )
If IsArray($Coord) Then MouseClick("Left",$Coord[0], $Coord[1],1,0)

This will work.

Damn it its not working ?!?!? what the hell

Share this post


Link to post
Share on other sites

Re verify that the color you are expecting is actually there with PixelGetColor()


[u]Helpful tips:[/u]If you want better answers to your questions, take the time to reproduce your issue in a small "stand alone" example script whenever possible. Also, make sure you tell us 1) what you tried, 2) what you expected to happen, and 3) what happened instead.[u]Useful links:[/u]BrettF's update to LxP's "How to AutoIt" pdfValuater's Autoit 1-2-3 Download page for the latest versions of Autoit and SciTE[quote]<glyph> For example - if you came in here asking "how do I use a jackhammer" we might ask "why do you need to use a jackhammer"<glyph> If the answer to the latter question is "to knock my grandmother's head off to let out the evil spirits that gave her cancer", then maybe the problem is actually unrelated to jackhammers[/quote]

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

this dont work for me damn i tryed an tricks on my destop (Start)

And it dont go on :S

it click but dont go on

Edited by Xav

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0