Jump to content
Sign in to follow this  
ame1011

GuiCtrlSetData "00000"

Recommended Posts

ame1011

Hi I'm trying to set the data in an input to "00000".

However, that string somehow gets converted to '0' and that's what is written to the input.

I tried using String("00000") and StringFormat(%s, "00000") but neither worked.

Any ideas?


[font="Impact"] I always thought dogs laid eggs, and I learned something today. [/font]

Share this post


Link to post
Share on other sites
Nahuel

Well... this sends "0000"

#include <GUIConstants.au3>

$Form1 = GUICreate("Form1", 257, 152, 193, 115)
$Input1 = GUICtrlCreateInput("", 56, 60, 129, 21)
GUISetState(@SW_SHOW)

GUICtrlSetData($Input1,"00000")

While 1
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case $GUI_EVENT_CLOSE
            Exit

    EndSwitch
WEnd

What kind of input are you working with?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.