Sign in to follow this  
Followers 0
Fabian

_WinAPI_SetParent

7 posts in this topic

I want to use an app (eg. notepad) in my form (as child). If I use _WinAPI_SetParent and I start the app it looks like this:

Posted Image

If I type something it looks like this:

Posted Image

And if I move the windowa a bit and type again a bit it looks like this:

Posted Image

What can I do that it looks like the third pic from the beginning?

Here's my code:

$Form1 = GUICreate("Form1", 1000, 650, 0, 0)
GUISetState(@SW_SHOW)
Run("notepad.exe")
WinWait("[CLASS:Notepad]")
$Notepad = WinGetHandle("[CLASS:Notepad]")
_WinAPI_SetParent($Notepad, $Form1)

embeded-mediaUDF ~~ Embed WMP, Quicktime and Flash in your Au3 appYABC ~~ Yet another Binary Clock

Share this post


Link to post
Share on other sites



where are you getting _WinAPI_SetParent ?


Agreement is not necessary - thinking for one's self is!

My-Colors.jpg

cuniform2.gif

Share this post


Link to post
Share on other sites

The helpfile in V3.2.10.0

Ok, thanks ... I'm still using 3.2.8.1.

Agreement is not necessary - thinking for one's self is!

My-Colors.jpg

cuniform2.gif

Share this post


Link to post
Share on other sites

_WinAPI_RedrawWindow only redraws the client area, not the menus and the border and if I define an update rect it does nothing. Can anybody help?


embeded-mediaUDF ~~ Embed WMP, Quicktime and Flash in your Au3 appYABC ~~ Yet another Binary Clock

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0