Sign in to follow this  
Followers 0
zeng

"ByRef $o_object" in IE Management

3 posts in this topic

#1 ·  Posted (edited)

This is a totally newbie question. I was not able to figure out how to do the 2nd step: (1) click link#4 from URL1, which becomes URL2, (2) click link #5 from URL2

#include <IE.au3>

$oIE = _IEcreate (URL1)

_IELinkClickByIndex ($oIE, 4)

winwait (URL2)

_IELinkClickByIndex (?, 5)

What do I use for ? Since URL2 was arrived by clicking from URL1, I cannot use IEcreate or IENavigate to assign new $oIE, what is the solution?

Thanks.

Edited by zeng

Share this post


Link to post
Share on other sites



This is a totally newbie question. I was not able to figure out how to do the 2nd step: (1) click link#4 from URL1, which becomes URL2, (2) click link #5 from URL2

#include <IE.au3>

$oIE = _IEcreate (URL1)

_IELinkClickByIndex ($oIE, 4)

winwait (URL2)

_IELinkClickByIndex (?, 5)

What do I use for ? Since URL2 was arrived by clicking from URL1, I cannot use IEcreate or IENavigate to assign new $oIE, what is the solution?

Thanks.

Ah, but here you will find something interesting. Hopefully the following will help you understand :)

#include <IE.au3>
$oIe = _IECreate ("www.autoitscript.com", 1, 1, 1)
$location = _IEPropertyGet ($oIe, "locationurl")
MsgBox (0, "Location of $oIe is...", $location)
_IENavigate ($oIe, "www.google.com", 1)
$location = _IEPropertyGet ($oIe, "locationurl")
MsgBox (0, "Location of $oIe is...", $location)

Not quite sure where your problem is, as I don't have enough of your code to test with, now what the website is. I'm sure Dale will pop in later to clear up any other questions...

Share this post


Link to post
Share on other sites

This is a totally newbie question. I was not able to figure out how to do the 2nd step: (1) click link#4 from URL1, which becomes URL2, (2) click link #5 from URL2

#include <IE.au3>

$oIE = _IEcreate (URL1)

_IELinkClickByIndex ($oIE, 4)

winwait (URL2)

_IELinkClickByIndex (?, 5)

What do I use for ? Since URL2 was arrived by clicking from URL1, I cannot use IEcreate or IENavigate to assign new $oIE, what is the solution?

Thanks.

You should use _IELinkClickByIndex ($oIE, 5). $oIE points (maybe not the correct word) to the window, not to the url if that makes any sense. Also if you want to wait until the page is loaded completely I sugest you use _IELoadWait() instead of winwait.

I hope I helped you.


I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0