Sign in to follow this  
Followers 0
MrChris

ActiveX Popup in IE.AU3

1 post in this topic

#1 ·  Posted (edited)

One of my scripts Im working on uses IE.Au3 include to create a internet explorer window in my GUI and navigates to a webpage. That webpage attempts to install and run an ActiveX applet. The problem is Im not getting that yellow bar up at the top of the page in my GUI like IE7 prompts when trying to download a file or run an active x script.

Below is my function. I think I based it off tweeking the sample in the help.

Thanks for any help,

Func SymantecScan()
    _IEErrorHandlerRegister ()
    $oIE = _IECreateEmbedded ()
    GUICreate("Symantec Security Scan", 800, 561, _
            (@DesktopWidth - 800) / 2, (@DesktopHeight - 570) / 2, _
            $WS_OVERLAPPEDWINDOW + $WS_VISIBLE + $WS_CLIPSIBLINGS)
    $GUIActiveX = GUICtrlCreateObj($oIE, 1, 1, 800, 560)
    GUISetState()       ;Show GUI
    _IENavigate ($oIE, "http://security.symantec.com/sscv6/home.asp")
    While 1
        $msg = GUIGetMsg()
        Select
            Case $msg = $GUI_EVENT_CLOSE
                ExitLoop
        EndSelect
    WEnd
GUIDelete()
EndFunc
Edited by MrChris

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0