Sign in to follow this  
Followers 0
supersonic

ComboBox works with XP/2003 but not with 2000

5 posts in this topic

hi

i noticed a strange behaviour using a ComboBox.

under XP/2003 it is no problem to drop down the list.

but trying to drop down the list under 2000 fails.

selecting an entry by using cursor or mouse wheel works fine.

any ideas?

Share this post


Link to post
Share on other sites



but trying to drop down the list under 2000 fails.

selecting an entry by using cursor or mouse wheel works fine.

I've had this problem also. The combo works normally in Win2000 except for it's height is set to 1 pixel. That's why you don't see the list.

From manual:

"Under Windows XP/2003 Windows will ajust the size of the opened combo. On other Windows versions you can define this size with the "height" parameter if the default value is not BIG enough to contain at least one line."

Try some manual height, maybe it helps?

Share this post


Link to post
Share on other sites

here's the way i create the ComboBox:

Global $locationComboBox = GUICtrlCreateCombo($locationselection, 5, 330, 590, 21, $CBS_DROPDOWNLIST)

i have no idea what's wrong with it...

I've had this problem also. The combo works normally in Win2000 except for it's height is set to 1 pixel. That's why you don't see the list.

From manual:

"Under Windows XP/2003 Windows will ajust the size of the opened combo. On other Windows versions you can define this size with the "height" parameter if the default value is not BIG enough to contain at least one line."

Try some manual height, maybe it helps?

Share this post


Link to post
Share on other sites

here's the way i create the ComboBox:

Global $locationComboBox = GUICtrlCreateCombo($locationselection, 5, 330, 590, 21, $CBS_DROPDOWNLIST)

i have no idea what's wrong with it...

Set the Height to 120 or Higher and should work fine


SciTE for AutoItDirections for Submitting Standard UDFs

 

Don't argue with an idiot; people watching may not be able to tell the difference.

 

Share this post


Link to post
Share on other sites

i can't believe it, but it's true...

thank you!

Set the Height to 120 or Higher and should work fine

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0