Sign in to follow this  
Followers 0
BigDog

after update to 3.2.10 ...

10 posts in this topic

dear all ,

today , i update autoit3 from 3.2.6 to 3.2.10 and then

run my script interface0.au3 , i got this error :

--------------------------------------------------------------------

C:\Program Files\AutoIt3\Include\IE.au3 (4088) : ==> Subscript used with non-Array variable.:

If IsObj($aRet[4]) Then

If IsObj($aRet^ ERROR

->16:24:40 AutoIT3.exe ended.rc:1

>Exit code: 1 Time: 77.170

--------------------------------------------------------------------

but , i ran this script at 3.2.6 , she works correct .

what should i do ? help please !

Share this post


Link to post
Share on other sites



dear all ,

today , i update autoit3 from 3.2.6 to 3.2.10 and then

run my script interface0.au3 , i got this error :

--------------------------------------------------------------------

C:\Program Files\AutoIt3\Include\IE.au3 (4088) : ==> Subscript used with non-Array variable.:

If IsObj($aRet[4]) Then

If IsObj($aRet^ ERROR

->16:24:40 AutoIT3.exe ended.rc:1

>Exit code: 1 Time: 77.170

--------------------------------------------------------------------

but , i ran this script at 3.2.6 , she works correct .

what should i do ? help please !

It means that $aRet[] does not have 5 elements when you're trying to access it. To find the problem you really need to post more code.

Oh and you're a bit on the late side. You can download the 3.2.12.0 rc 2 now :)


Broken link? PM me and I'll send you the file!

Share this post


Link to post
Share on other sites

It means that $aRet[] does not have 5 elements when you're trying to access it. To find the problem you really need to post more code.

Oh and you're a bit on the late side. You can download the 3.2.12.0 rc 2 now :)

-----------------------------------------------------

...

_IEFormImageClick ( $oIE, "/xx/xx.gif", "src")

WinActivate ( "讀取憑證 -- 網頁對話" ) ; active is needed

#Region ; 2008-5-6

$oCAwin = _IEAttach("讀取憑證 -- 網頁對話","DialogBox") ; <----- err occur after this line ,

;$oCAform = _IEFormGetObjByName ($oCAwin, "form1")

_IEImgClick ($oCAwin, "/xxxx/xx.gif", "src")

#EndRegion

...

-----------------------------------------------------

thank you , where to download 3.2.12 ?

Share this post


Link to post
Share on other sites

-----------------------------------------------------

...

_IEFormImageClick ( $oIE, "/xx/xx.gif", "src")

WinActivate ( "讀取憑證 -- 網頁對話" ) ; active is needed

#Region ; 2008-5-6

$oCAwin = _IEAttach("讀取憑證 -- 網頁對話","DialogBox") ; <----- err occur after this line ,

;$oCAform = _IEFormGetObjByName ($oCAwin, "form1")

_IEImgClick ($oCAwin, "/xxxx/xx.gif", "src")

#EndRegion

...

-----------------------------------------------------

thank you , where to download 3.2.12 ?

Still not much, the important thing is where does $aRet come from?

You can download 3.2.12.0 here :)


Broken link? PM me and I'll send you the file!

Share this post


Link to post
Share on other sites

Still not much, the important thing is where does $aRet come from?

You can download 3.2.12.0 here :)

i never set that vars ($aRet) ?

and the strange thing is : the same code work [correct] at another pc with 3.2.6 !

Share this post


Link to post
Share on other sites

Aah never mind, the error was in IE.au3 that's why...

I don't use the IE functions very much but maybe they have changed since the old version. Read up on the functions to see what's different. If you don't want to do that, install the old version compile it to an exe and install new version again.


Broken link? PM me and I'll send you the file!

Share this post


Link to post
Share on other sites

Aah never mind, the error was in IE.au3 that's why...

I don't use the IE functions very much but maybe they have changed since the old version. Read up on the functions to see what's different. If you don't want to do that, install the old version compile it to an exe and install new version again.

after i update to 3.2.12 , the error disappear !?

and i add a new line to my code "#include <StaticConstants.au3>" for $SS_CENTER

all other thing is correct !

thank you anyway , this is a strange thing !

Share this post


Link to post
Share on other sites

after i update to 3.2.12 , the error disappear !?

and i add a new line to my code "#include <StaticConstants.au3>" for $SS_CENTER

all other thing is correct !

thank you anyway , this is a strange thing !

ps:

how do i reinstall a older version on autoit3 ?

Share this post


Link to post
Share on other sites

I just assumed you had the old installer. I don't know where to download old versions but if you really need an old one I have some old versions lying around :)


Broken link? PM me and I'll send you the file!

Share this post


Link to post
Share on other sites

*GERMAN* [note: you are not allowed to remove author / modified info from my UDFs]My UDFs:[_SetImageBinaryToCtrl] [_TaskDialog] [AutoItObject] [Animated GIF (GDI+)] [ClipPut for Image] [FreeImage] [GDI32 UDFs] [GDIPlus Progressbar] [Hotkey-Selector] [Multiline Inputbox] [MySQL without ODBC] [RichEdit UDFs] [SpeechAPI Example] [WinHTTP]UDFs included in AutoIt: FTP_Ex (as FTPEx), _WinAPI_SetLayeredWindowAttributes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0