Sign in to follow this  
Followers 0
fabs

Help with _IEAction

5 posts in this topic

#1 ·  Posted (edited)

Hi!

I have made an auto login for the website marcophono.net (maybe some germans know this). You can call real german, austrian and suissian phone numbers. If you connected successfully (the servers may be full for the "not-premium-owner"), you can select several given answers which will be played and sent to the telephone number.

Because of the livestream in case of connecting successfully, _IELoadWait() doesn't work. So I made a Do-Until-Loop which checks the URL (error-URL oder success-URL). The loop knows when the connecting failed, but if you connected and the connection is made, the script pauses at the _IEFormSubmit() command (I confirmed this guess by using a MsgBox after _IEFormSubmit).

So I tried to replace _IEFormSubmit with _IEImgClicK() but it doesn't work how I want.

Func x()

;rest of x()...

_IEImgClick($oIE, "http://images.marcophono.net/images/anrufen.jpg")

MsgBox(64, "", "call func check()", 1)
    _check()
EndFunc

Func _check()
    MsgBox(64, "bla", "check() was called", 1)
;rest of func
EndFuncoÝ÷ Ù8^¥ªí¡ûazÊ.­Ç®­ìnÈ­z[b­·*^

It gets the current URL until the url is the normal url, which will be created if you have logged in or the url for full servers (not loggged in).

Something's wrong with the object but i dont know what.

Please help me to finish this script. :) Greetz fabs

Edited by fabs

Share this post


Link to post
Share on other sites



Warning from function _IEImgClick, $_IEStatus_NoMatch

Your call to _IEImgClick did not find a matching Img... the second error is the result of the first.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

I know what the error means. I have just no idea how to solve this error because there are no other strings with the imgname in the source of the website!

Are there any other ways to solve this problem? I want to make just a simple click on the button "anrufen" ( http://www.marcophono.net/flatrate_4_a.html )

Share this post


Link to post
Share on other sites

_IEImgClick($oIE, "http://images.marcophono.net/images/anrufen.jpg") will look for a tag in the HTML that looks like: <Img src="http://images.marcophono.net/images/anrufen.jpg">

If that is not what is in your HTML, then this won't work - you'll get NoMatch.

If you are having trouble with a pause after _IEFormSubmit, please read the remarks in the helpfile for that function and turn off the automatic LoadWait it uses, perhaps adding an _IELoadWait($oIE) after it.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Thanks, I used _IESubmit() with no automatic load wait. I had to modify a few of other lines, but it works!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0