Sign in to follow this  
Followers 0
amuskie

MouseMove or MouseClick within Remote Desktop

2 posts in this topic




Both MouseMove or MouseClick are not working within Remote Desktop. I found one related link but didn't have any solution:

http://www.autoitscript.com/forum/index.php?showtopic=21976

Any one know about how to resolve it? Thank!

I wrote a simple script using AutiItX, that's just supposed

to do a mouse LeftClick and move the cursor out of the active window.

If I run it on local machine, it works ok.

Unfortunately if I run it in "Remote Desktop" session, the LeftClick event is fired

and mouse coordinates are changes, but the cursor stay in the same place.

They r working as he did say that, but he dont understand why he dont see his mouse moving from one place to another.

You cant expect to see mouse move on remote desktop becose remote desktop isnt controling mouse on your local pc, its other way around.

So if your script is started on remote pc its working, but if you started it on local pc youl need to set local resources on remote desktop connection probably "On the local computer" before conecting to your remote sesion (if id remamber this part correct).


TCP server and client - Learning about TCP servers and clients connection
Au3 oIrrlicht - Irrlicht project
Au3impact - Another 3D DLL game engine for autoit. (3impact 3Drad related)



460px-Thief-4-temp-banner.jpg
There are those that believe that the perfect heist lies in the preparation.
Some say that it’s all in the timing, seizing the right opportunity. Others even say it’s the ability to leave no trace behind, be a ghost.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0