Sign in to follow this  
Followers 0
Dampe

user32.dll SetClipBoardData

2 posts in this topic

ClipPut (DllCall ("user32.dll", "int", "SetClipboardData", "CF_TEXT", "Test Message"))

always seems to put 0 on the clipboard, did I miss something? :S

(don't tell me to use clipget())


Share this post


Link to post
Share on other sites

#2 ·  Posted (edited)

ClipPut (DllCall ("user32.dll", "int", "SetClipboardData", "CF_TEXT", "Test Message"))

always seems to put 0 on the clipboard, did I miss something? :S

(don't tell me to use clipget())

DllCall returns an array

Edit: partially incorrect if call is 'GetClipboardData' instead of SetClipboardData

the call is formatted incorrectly

missing memory handling

see how _ClipBoard_GetData() is put together in ClipBoard.au3

Global Const $CF_TEXT = 1 
$aResult = DllCall("User32.dll", "hwnd", "GetClipboardData", "int", $CF_TEXT)oÝ÷ Úë¶*[¡ªÝP1býõÙ«­¢+Ø¥¹±Õ±ÐíÕ¥
½¹ÍѹÑÍà¹ÔÌÐì(¥¹±Õ±Ðí
±¥Á  ½É¹ÔÌÐì(¥¹±Õ±Ðí]¥¹½ÝÍ
½¹ÍѹÑ̹ÔÌÐì()=ÁÐ Ìäí5ÕÍѱÉYÉÌÌäì°Ä¤()±½°ÀÌØí¥5µ¼()}5¥¸ ¤()Õ¹}5¥¸ ¤(%1½°ÀÌØí¡U$°ÀÌØíѹ}MÑÑ°ÀÌØíѹ}ÑÑ(($ì
ÉÑU$($ÀÌØí¡U$ôU%
ÉÑ ÅÕ½Ðí
±¥Á½ÉÅÕ½Ðì°ØÀÀ°ÐÔÀ¤($ÀÌØí¥5µ¼ôU%
Ñɱ
ÉѥРÅÕ½Ðí¹ÑȵÍÍÅÕ½Ðì°È°È°ÔäØ°ÌäØ°ÀÌØí]M}YM
I=10¤(%U%
ÑɱMѽ¹Ð ÀÌØí¥5µ¼°ä°ÐÀÀ°À°ÅÕ½Ðí
½ÕÉ¥È9ÜÅÕ½Ðì¤($ÀÌØíѹ}MÑÑôU%
Ñɱ
ÉÑ    ÕÑѽ¸ ÅÕ½ÐíMÐ
±¥Á  ½ÉÑÅÕ½Ðì°ÄÔÀ°ÐÄÀ°ÄÈÀ°ÌÀ¤($ÀÌØíѹ}ÑÑôU%
Ñɱ
ÉÑ    ÕÑѽ¸ ÅÕ½ÐíÐ
±¥Á  ½ÉÑÅÕ½Ðì°ÌÀÀ°ÐÄÀ°ÄÈÀ°ÌÀ¤(%U%MÑMÑÑ ¤(($ì1½½Àչѥ°ÕÍÈá¥ÑÌ(%]¡¥±Ä($%MÝ¥Ñ U%Ñ5Í ¤($$%
ÍÀÌØíU%}Y9Q}
1=M($$$%á¥Ñ1½½À($$%
ÍÀÌØíѹ}MÑÑ($$$%}
±¥Á  ½É}MÑÑ¡U%
ÑɱI ÀÌØí¥5µ¼¤¤($$%
ÍÀÌØíѹ}ÑÑ($$$%5µ½]ɥѡ}
±¥Á  ½É}ÑÑ ¤¤($%¹MÝ¥Ñ (%]¹()¹Õ¹ìôôÐí}5¥¸((ì]ɥѵÍÍѼµµ¼)Õ¹5µ½]É¥Ñ ÀÌØíÍ5ÍÍôÅÕ½ÐìÅÕ½Ðì¤(%U%
ÑɱMÑÑ ÀÌØí¥5µ¼°ÀÌØíÍ5Í͵Àì
I1°Ä¤)¹Õ¹ìôôÐí5µ½]É¥Ñ
Edited by rover

I see fascists...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0