Sign in to follow this  
Followers 0
JusGellin

Scite Doesn't Run Scripts Suddenly

18 posts in this topic

Suddenly Scite doesn't run scripts anymore. I've uninstalled/reinstalled AutoIt but it doesn't help. I get the following similar to when I run a any script from Scite:

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "D:\Index\Autoit\Scripts\Test\test2.au3" /autoit3dir "C:\Program Files\AutoIt3" /UserParams

>The system cannot find the file specified.

The paths work fine.

I can right click on a script from explorer and it can run from there fine. What can I do? Thanks

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

What AutoIt version you are using?

And what the exact path to AutoIt install directory?

Check in the SciTE directory the file «...\SciTe\properties\au3.properties», and post here the lines with:

# *** Specify here your AutoIt program directory  ***
autoit3dir=.....

and search in this file the line with:

command.go.$(au3)=....

post it here as well.

Edited by MrCreatoR

 

Spoiler

Using OS: Win 7 Professional, Using AutoIt Ver(s): 3.3.6.1 / 3.3.8.1

AutoIt_Rus_Community.png AutoIt Russian Community

My Work...

Spoiler

AutoIt_Icon_small.pngProjects: ATT - Application Translate Tool {new}| BlockIt - Block files & folders {new}| SIP - Selected Image Preview {new}| SISCABMAN - SciTE Abbreviations Manager {new}| AutoIt Path Switcher | AutoIt Menu for Opera! | YouTube Download Center! | Desktop Icons Restorator | Math Tasks | KeyBoard & Mouse Cleaner | CaptureIt - Capture Images Utility | CheckFileSize Program

AutoIt_Icon_small.pngUDFs: OnAutoItErrorRegister - Handle AutoIt critical errors {new}| AutoIt Syntax Highlight {new}| Opera Library! | Winamp Library | GetFolderToMenu | Custom_InputBox()! | _FileRun UDF | _CheckInput() UDF | _GUIInputSetOnlyNumbers() UDF | _FileGetValidName() UDF | _GUICtrlCreateRadioCBox UDF | _GuiCreateGrid() | _PathSplitByRegExp() | _GUICtrlListView_MoveItems - UDF | GUICtrlSetOnHover_UDF! | _ControlTab UDF! | _MouseSetOnEvent() UDF! | _ProcessListEx - UDF | GUICtrl_SetResizing - UDF! | Mod. for _IniString UDFs | _StringStripChars UDF | _ColorIsDarkShade UDF | _ColorConvertValue UDF | _GUICtrlTab_CoverBackground | CUI_App_UDF | _IncludeScripts UDF | _AutoIt3ExecuteCode | _DragList UDF | Mod. for _ListView_Progress | _ListView_SysLink | _GenerateRandomNumbers | _BlockInputEx | _IsPressedEx | OnAutoItExit Handler | _GUICtrlCreateTFLabel UDF | WinControlSetEvent UDF | Mod. for _DirGetSizeEx UDF
 
AutoIt_Icon_small.pngExamples: 
ScreenSaver Demo - Matrix included | Gui Drag Without pause the script | _WinAttach()! | Turn Off/On Monitor | ComboBox Handler Example | Mod. for "Thinking Box" | Cool "About" Box | TasksBar Imitation Demo

Like the Projects/UDFs/Examples? Please rate the topic (up-right corner of the post header: Rating AutoIt_Rating.gif)

* === My topics === *

==================================================
My_Userbar.gif
==================================================

 

 

 

AutoIt is simple, subtle, elegant. © AutoIt Team

Share this post


Link to post
Share on other sites

Did you actually check the directory if this file does exists on this PC?

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe"

If so, do you have enough Rights to the directory?

:)


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Did you actually check the directory if this file does exists on this PC?

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe"

If so, do you have enough Rights to the directory?

:)

I have local admin rights on this PC. I also have the directory you mentioned except the file is called AutoIt3Wrapper_GUI.exe

Share this post


Link to post
Share on other sites

I have local admin rights on this PC. I also have the directory you mentioned except the file is called AutoIt3Wrapper_GUI.exe

You should have both, try reinstalling SciTE.

Share this post


Link to post
Share on other sites

What AutoIt version you are using?

And what the exact path to AutoIt install directory?

Check in the SciTE directory the file «...\SciTe\properties\au3.properties», and post here the lines with:

# *** Specify here your AutoIt program directory  ***
 autoit3dir=.....

and search in this file the line with:

command.go.$(au3)=....

post it here as well.

Mine is found at: C:\Program Files\AutoIt3\SciTE\Properties

Mine is C:\Program Files\AutoIt3

command.go.$(au3)="$(SciteDefaultHome)\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in

Share this post


Link to post
Share on other sites

You should have both, try reinstalling SciTE.

I uninstalled and tried to reinstall. Then McAfee said I had a trojan virus and said it fixed this. So the install of Site continued. But it doesn't work again. It appears that McAfee did something to it. This is what it says: "Tojan Removed McAfee has automatically blocked and removed a Trojan.

About this Trojan

Detected: Generic.dx (Trojan), Generic.dx (Trojan)

Location: C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe

"

What a bother! What can I do now?

Share this post


Link to post
Share on other sites

What can I do now?

Add «AutoIt3Wrapper.exe» to the exclude list (in the antivirus settings), and then install SciTE again :)

 

Spoiler

Using OS: Win 7 Professional, Using AutoIt Ver(s): 3.3.6.1 / 3.3.8.1

AutoIt_Rus_Community.png AutoIt Russian Community

My Work...

Spoiler

AutoIt_Icon_small.pngProjects: ATT - Application Translate Tool {new}| BlockIt - Block files & folders {new}| SIP - Selected Image Preview {new}| SISCABMAN - SciTE Abbreviations Manager {new}| AutoIt Path Switcher | AutoIt Menu for Opera! | YouTube Download Center! | Desktop Icons Restorator | Math Tasks | KeyBoard & Mouse Cleaner | CaptureIt - Capture Images Utility | CheckFileSize Program

AutoIt_Icon_small.pngUDFs: OnAutoItErrorRegister - Handle AutoIt critical errors {new}| AutoIt Syntax Highlight {new}| Opera Library! | Winamp Library | GetFolderToMenu | Custom_InputBox()! | _FileRun UDF | _CheckInput() UDF | _GUIInputSetOnlyNumbers() UDF | _FileGetValidName() UDF | _GUICtrlCreateRadioCBox UDF | _GuiCreateGrid() | _PathSplitByRegExp() | _GUICtrlListView_MoveItems - UDF | GUICtrlSetOnHover_UDF! | _ControlTab UDF! | _MouseSetOnEvent() UDF! | _ProcessListEx - UDF | GUICtrl_SetResizing - UDF! | Mod. for _IniString UDFs | _StringStripChars UDF | _ColorIsDarkShade UDF | _ColorConvertValue UDF | _GUICtrlTab_CoverBackground | CUI_App_UDF | _IncludeScripts UDF | _AutoIt3ExecuteCode | _DragList UDF | Mod. for _ListView_Progress | _ListView_SysLink | _GenerateRandomNumbers | _BlockInputEx | _IsPressedEx | OnAutoItExit Handler | _GUICtrlCreateTFLabel UDF | WinControlSetEvent UDF | Mod. for _DirGetSizeEx UDF
 
AutoIt_Icon_small.pngExamples: 
ScreenSaver Demo - Matrix included | Gui Drag Without pause the script | _WinAttach()! | Turn Off/On Monitor | ComboBox Handler Example | Mod. for "Thinking Box" | Cool "About" Box | TasksBar Imitation Demo

Like the Projects/UDFs/Examples? Please rate the topic (up-right corner of the post header: Rating AutoIt_Rating.gif)

* === My topics === *

==================================================
My_Userbar.gif
==================================================

 

 

 

AutoIt is simple, subtle, elegant. © AutoIt Team

Share this post


Link to post
Share on other sites

Add «AutoIt3Wrapper.exe» to the exclude list (in the antivirus settings), and then install SciTE again :)

McAfee doesn't easily allow me to do that. I'm trying to figure this out yet.

But I did find that if I reinstall an older version of SciTE4AutoIt3.exe with a file size of 4,122 KB, it works ok. So it looks like this problem occurs with the one more recently downloaded with a size of 4,256 KB.

Thanks

Share this post


Link to post
Share on other sites

The Organization I work for has talked with McAfee and they are working on it. For now just exclude it.


Triton

Share this post


Link to post
Share on other sites

*UPDATE*

McAfee has autoit3wrapper.exe and is addressing the Issue. If you have McAfee via enterprise network, it will need to be excluded at the server level. Also vnc is suffering from the same fate.

I will update as I am updated!


Triton

Share this post


Link to post
Share on other sites

But I did find that if I reinstall an older version of SciTE4AutoIt3.exe with a file size of 4,122 KB, it works ok.

Where did you find the version archives? I am experiencing the same problem and do not have access to McAfee settings here at work. :)


IE Dev ToolbarMSDN: InternetExplorer ObjectMSDN: HTML/DHTML Reference Guide[quote]It is surprising what a man can do when he has to, and how little most men will do when they don't have to. - Walter Linn[/quote]--------------------[font="Franklin Gothic Medium"]Post a reproducer with less than 100 lines of code.[/font]

Share this post


Link to post
Share on other sites

Where did you find the version archives? I am experiencing the same problem and do not have access to McAfee settings here at work. :)

I found it on another PC I had.

Share this post


Link to post
Share on other sites

I also had this problem. My Co-worker could execute scripts, but I could not with the same error "Error opening the dstination file.". The really odd thing is that sometimes it would work. I would continually work on it and then it would suddenly compile, and right after it would not compile again!

After reading this, I decided to turn off my "active shield" on my AVG, and it compiled every time after that. I also tried to add the processes as an exception, but what is happening and most Anti-Viruses do this is that the Anti-Virus software is taking ownership of the file and locking it down. This disallows AutoIt to continue compiling. So when AutoIT creates a temp file for its compile, AVG is grabbing it and not letting it go until it is scanned.

The quick fix would be to have AutoIT add a compile delay to deal with this.

Share this post


Link to post
Share on other sites

Today we received a sdat that still detected it as a trogan but did not delete it. I am told that we Should have a good working sdat by tomorrow and I will update all as I am updated


Triton

Share this post


Link to post
Share on other sites

#17 ·  Posted (edited)

My AVG is telling that:

Virus identified Worm/Autoit.DDH

it's on AuoIt3Wrapper.exe

detected on close (during installation).

This hapens today when I tried to sintax chek an au3, in the version I had installed on my PC for about 2-3 weeks.

So I uninstalled AU3, download a new version and during instalation it gave the same message for the wrapper.

In AVG is simple to ignore it, but I'm affraid if it is secure to ignore OR if the version I just downloaded from http://www.autoitscript.com/autoit3/scite/...iTE4AutoIt3.exe is OK.

thanks

Jose

Edited by joseLB

Share this post


Link to post
Share on other sites

My AVG is telling that:

Virus identified Worm/Autoit.DDH

it's on AuoIt3Wrapper.exe

detected on close (during installation).

This hapens today when I tried to sintax chek an au3, in the version I had installed on my PC for about 2-3 weeks.

So I uninstalled AU3, download a new version and during instalation it gave the same message for the wrapper.

In AVG is simple to ignore it, but I'm affraid if it is secure to ignore OR if the version I just downloaded from http://www.autoitscript.com/autoit3/scite/...iTE4AutoIt3.exe is OK.

thanks

Jose

Looks like Mcafee fixed there problem. The last few days I had to use the roll back dat feature to allow my scripts to test in the scite editor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0